Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182046 - HAL fails to remove mount point for floppy device after unmounting
Summary: HAL fails to remove mount point for floppy device after unmounting
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
: 182693 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-19 18:53 UTC by William Shotts
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-01 13:14:28 UTC


Attachments (Terms of Use)

Description William Shotts 2006-02-19 18:53:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
Unlike other devices, when a floppy is unmounted its mount point in /media is not removed.  This seems to cause problems for both KDE and GNOME regarding floppy mounting.

Version-Release number of selected component (if applicable):
hal-0.5.7-0.cvs20060213.1

How reproducible:
Always

Steps to Reproduce:
1. Using a file manager (Konqueror or Nautilus) mount a floppy
2. Note creation of mount point in /media 
3. Unmount floppy in file manager
  

Actual Results:  Mount point remains after floppy is unmounted

Expected Results:  Mount point is removed

Additional info:

Additional attempts to mount floppy results in build up of mount points.  Further, Konqueror never offers an unumount option for the floppy.

Comment 1 David Zeuthen 2006-02-20 17:13:04 UTC
Does 'gnome-umount --block --no-ui --device /dev/fd0' do the right thing?

Comment 2 William Shotts 2006-02-20 17:33:30 UTC
Yes. 'gnome-umount --block --no-ui --device /dev/fd0' unmounts it and removes
the mount point in /media.

Comment 3 David Zeuthen 2006-02-20 17:40:25 UTC
Right.. we need a small patch for gnome-vfs to do the right thing. Shouldn't be
terribly difficult, we just need gnome-vfs to use gnome-mount when the
GnomeVFSDrive is known by hal but the GnomeVFSVolume isn't. 

I don't know how the KDE bits work, someone needs to open a separate bug for
these bits as I'm reassigning this bug to gnome-vfs2.

Comment 4 David Zeuthen 2006-02-21 17:57:32 UTC
I've posted a patch to upstream here

 http://mail.gnome.org/archives/gnome-vfs-list/2006-February/msg00037.html


Comment 5 David Zeuthen 2006-02-25 00:25:26 UTC
Patch mentioned in comment 4 is now upstream. Will be included in new gnome-vfs2
packages sometime next week.

Comment 6 David Zeuthen 2006-02-25 00:25:50 UTC
*** Bug 182693 has been marked as a duplicate of this bug. ***

Comment 7 Matthias Clasen 2006-03-01 13:14:28 UTC
The patch mentioned in comment #4 is in gnome-vfs2-2.13.92, so I assume this is
fixed.

Comment 8 Michal Jaegermann 2006-03-01 16:26:00 UTC
Yes, indeed, it looks that this works now as expected.


Note You need to log in before you can comment on or make changes to this bug.