Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 182028 - Firefox (and Mozilla) exit when opening large .gif
Summary: Firefox (and Mozilla) exit when opening large .gif
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL: http://veimages.gsfc.nasa.gov//1438/n...
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-19 11:34 UTC by Jukka Ketelaars
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-21 19:00:35 UTC


Attachments (Terms of Use)
strace firefox http://veimages.gsfc.nasa.gov//1438/nightearth.gif (deleted)
2006-02-24 19:29 UTC, Jukka Ketelaars
no flags Details
xorg.conf (deleted)
2006-03-02 20:15 UTC, Jukka Ketelaars
no flags Details

Description Jukka Ketelaars 2006-02-19 11:34:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060210 Fedora/1.5.0.1-3 Firefox/1.5.0.1

Description of problem:
When opeing a url that points to a large gif, Firefox exits. No stack trace or any other info appears.

Version-Release number of selected component (if applicable):
firefox-1.5.0.1-3

How reproducible:
Always

Steps to Reproduce:
1. start firefox from the command line
2. open http://veimages.gsfc.nasa.gov//1438/nightearth.gif

  

Actual Results:  Firefox window disappears

Expected Results:  An image to be displayed, or an error message that the image is too large.

Additional info:

According to http://visibleearth.nasa.gov/view_detail.php?id=1438 the image size is 30000 x 15000

Comment 1 Matthias Clasen 2006-02-21 20:53:27 UTC
Doesn't happen on this x86_64 box. It doesn't display anything, but it does not
crash.

Comment 2 Christopher Aillon 2006-02-23 21:13:39 UTC
It doesn't happen on my i386 either...

Comment 3 Jukka Ketelaars 2006-02-24 19:29:06 UTC
Created attachment 125202 [details]
strace firefox http://veimages.gsfc.nasa.gov//1438/nightearth.gif 

Looks like a resource problem in X.

Comment 4 Matthias Clasen 2006-03-01 14:52:56 UTC
Jukka, you attached the gif again, not the strace

Comment 5 Jukka Ketelaars 2006-03-01 16:42:40 UTC
It looks to me like the strace is in bugzilla
(https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=125202). If not please
let me know and I'll upload it again. The gif is there because I pasted the
strace command as entered.

Comment 6 Christopher Aillon 2006-03-01 16:45:08 UTC
How much memory do you have, and could you post your xorg.conf?

Comment 7 Jukka Ketelaars 2006-03-02 20:15:52 UTC
Created attachment 125565 [details]
xorg.conf

xorg.conf attached. Memory is 1GB.


Note You need to log in before you can comment on or make changes to this bug.