Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 181963 - Anaconda should create fstab entry for vfat partitions with 'utf8' option
Summary: Anaconda should create fstab entry for vfat partitions with 'utf8' option
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
: 192541 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-17 23:40 UTC by Dawid Gajownik
Modified: 2015-01-04 22:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-05 05:37:33 UTC


Attachments (Terms of Use)

Description Dawid Gajownik 2006-02-17 23:40:43 UTC
Description of problem:
Default locale in Fedora is set to UTF-8 (for instance en_US.UTF-8 or
pl_PL.UTF-8). Without 'utf8' mount option, file names with non US-ASCII
characters on vfat partitions are not shown correctly.

Version-Release number of selected component (if applicable):
anaconda-10.92.5-1

How reproducible:
Run installator and in custom partition layout choose existing vftat partition.
Assign to it /mnt/data mount point. After reboot check /etc/fstab.

Actual results:
'defaults' option is used for vfat partition.

Expected results:
Should be 'defaults,utf8'

Comment 1 Jeremy Katz 2006-02-20 20:46:03 UTC
Actually, the kernel should just be defaulting to the right option :-)

Comment 2 Dave Jones 2006-03-05 05:37:33 UTC
Done.


Comment 3 Andy Shevchenko 2006-05-05 08:40:32 UTC
What about non-UTF-8 locales?
When I try to use the usb flash (for example) in localized windows and linux 
boxes the last brings incorrect file- and dirnames (only utf8fied independly of 
iocharset option). It is no good behaviour for me (I'm using uk_UA.KOI8-U locale 
on my linux box).


Comment 4 Andy Shevchenko 2006-05-05 08:46:38 UTC
In addition, I think may be more good to use 
  CONFIG_FAT_DEFAULT_CODEPAGE=437
  CONFIG_FAT_DEFAULT_IOCHARSET="utf8"
or something like that?


Comment 5 Andrew Zabolotny 2006-05-21 17:27:51 UTC
*** Bug 192541 has been marked as a duplicate of this bug. ***

Comment 6 Andrew Zabolotny 2006-05-21 17:35:27 UTC
Had to dig through kernel SRPM to find a solution for my problem ;-( I don't
think that's the correct way for end users.

After looking at fs/fat/inode.c I found the utf8=0 (and the equivalent
utf8=false) options which solve my problem when using a non-UTF8 locale, which
is undocumented in "man mount". However, I think the solution to make utf8
enabled by default is kind of crude.

The least that should be done is to add info about "utf8=0" option to the man
page, because that was the first place where I was looking for an answer.

But I still think that changing Anaconda to add the "utf8" mount option would be
better.



Note You need to log in before you can comment on or make changes to this bug.