Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 181595 - grub not properly cleaned out on upgrade
Summary: grub not properly cleaned out on upgrade
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-15 01:03 UTC by Bill Nottingham
Modified: 2014-03-17 02:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-27 21:29:43 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2006-02-15 01:03:27 UTC
Description of problem:

After upgrading, my grub.conf has references to old kernels, even though they've
been removed.

Version-Release number of selected component (if applicable):

rawhide-20060214.2

How reproducible:

Happened once, haven't tried.

Steps to Reproduce:
1. Install FC2. (2.6.5-1.358smp)
2. yum upgrade to the latest update kernel (now have 2.6.5-1.358smp and
2.6.10-1.771_FC2smp)
3. Upgrade with anaconda. Now I only have 2.6.15-1.1948_FC5 installed.

Actual results:

grub.conf contains:

...
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.5-1.358smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.5-1.358smp ro root=/dev/vg0/lv0 rhgb quiet
title Fedora Core-smp (2.6.10-1.771_FC2smp)
        root (hd0,0)
        kernel /vmlinuz-2.6.10-1.771_FC2smp ro root=/dev/vg0/lv0 rhgb quiet
title Fedora Core-up (2.6.15-1.1948_FC5)
        root (hd0,0)
        kernel /vmlinuz-2.6.15-1.1948_FC5 ro root=/dev/vg0/lv0 rhgb quiet
        initrd /initrd-2.6.15-1.1948_FC5.img


Expected results:

grub.conf only contains the last stanza.

Additional info:

No noise in upgrade.log. I suppose it's possible that the new-kernel-pkg
--remove calls got befuddled due to bug 181593.

Comment 1 Jeremy Katz 2006-02-15 19:55:21 UTC
Yeah, that would almost certainly make things confused.

Comment 2 Jeremy Katz 2006-02-27 21:29:43 UTC
This should be better now afaict


Note You need to log in before you can comment on or make changes to this bug.