Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 181571 - Kickstart install cannot partition disk
Summary: Kickstart install cannot partition disk
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-02-14 22:36 UTC by Orion Poplawski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-08 21:15:47 UTC


Attachments (Terms of Use)
anaconda log (deleted)
2006-02-14 22:36 UTC, Orion Poplawski
no flags Details

Description Orion Poplawski 2006-02-14 22:36:55 UTC
Description of problem:
Install with 20060214 rawhide fails to partition the disk.  ks below and
anaconda.log attached.

install
text
nfs --server=saga --dir=/export/data1/fedora/core/development/i386
lang en_US
keyboard us
network --bootproto=dhcp
rootpw --iscrypted CwU/lYtazWt7E
firewall --disabled
authconfig --enableshadow --enablenis --nisdomain=yp.colorado-research.com
timezone America/Denver
xconfig --startxonboot --defaultdesktop=KDE --resolution=1600x1200 --depth=24
bootloader --location=mbr
clearpart --linux --drives=hda
part /boot --fstype ext3 --size=50
part pv.1 --size 4800 --grow
volgroup rootvg pv.1
logvol / --vgname=rootvg --size=512 --name=root
logvol swap --fstype=swap --vgname=rootvg --recommended --name=swap
logvol /usr --vgname=rootvg --size=4000 --name=usr
logvol /var --vgname=rootvg --size=256 --name=var
logvol /export/data1 --vgname=rootvg --size=1 --name=data1 --grow
reboot

Comment 1 Orion Poplawski 2006-02-14 22:36:56 UTC
Created attachment 124651 [details]
anaconda log

Comment 2 Orion Poplawski 2006-02-14 22:39:17 UTC
Screen shows:

Error partitioning

Could not allocate requested partitions:

Partitioning failed: Could not allocate partitions.

Press 'OK' to reboot your system.

Single IDE disk with empty partition table.

Comment 3 Chris Lumens 2006-02-15 15:51:41 UTC
What happens if you make your /var partition at least 384 megs and your /boot
partition at least 75 megs?

Comment 4 Orion Poplawski 2006-02-15 16:17:27 UTC
No effect.  FYI - this kickstart file has worked for me for a long time.

Comment 5 Chris Lumens 2006-02-15 21:21:25 UTC
Hm, I'm unable to reproduce your bug on a machine here with the same ks
partitioning information and one IDE disk I wiped the partition table from.  Can
you think of anything that might help me to reproduce this one?

Comment 6 Orion Poplawski 2006-02-15 21:38:45 UTC
Crap!  I am so sorry - I'm using a 4GB disk and it doesn't fit.  Perhaps a
better error message (there is not enough space to allocate the requested
partions) to help idiots like me?

Comment 7 Chris Lumens 2006-02-15 21:43:00 UTC
Better error messages for this partitioning stuff would be very helpful, but
it's too late for FC5 to do anything about that (after freeze for translations,
etc).  Moving to FC6Target so we can try to get it done for then.

Comment 8 Chris Lumens 2006-06-08 21:15:47 UTC
We can now do a better job on this particular error message.  The partitioning
code is kind of a maze, though, so I'm not going to be able to track down every
bad error message.  If you run into another one that makes no sense, please file
another bug.


Note You need to log in before you can comment on or make changes to this bug.