Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 181456 - 3D software rendering broken
Summary: 3D software rendering broken
Keywords:
Status: CLOSED DUPLICATE of bug 190245
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC6Target FC5Update
TreeView+ depends on / blocked
 
Reported: 2006-02-14 12:00 UTC by Pawel Salek
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-27 17:47:28 UTC


Attachments (Terms of Use)
Xorg.0.log (deleted)
2006-02-14 12:54 UTC, Pawel Salek
no flags Details
xorg.conf (deleted)
2006-02-14 12:55 UTC, Pawel Salek
no flags Details

Description Pawel Salek 2006-02-14 12:00:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
When I try to run glxgears, I get
$ glxgears
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  144 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  22
  Current serial number in output stream:  22


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.0.1-6.1

How reproducible:
Always

Steps to Reproduce:
1. try running glxgears.


Additional info:

This is a SiS graphics card with no hardware accelleration.
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760/761 PCI/AGP VGA Display Adapter (rev 03)

This problem was mentioned in passing in:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176976

Comment 1 Mike A. Harris 2006-02-14 12:34:48 UTC
Please attach X server log/config as individual attachments for review.

TIA

Comment 2 Pawel Salek 2006-02-14 12:54:47 UTC
Created attachment 124613 [details]
Xorg.0.log

Comment 3 Pawel Salek 2006-02-14 12:55:29 UTC
Created attachment 124614 [details]
xorg.conf

Comment 4 Pawel Salek 2006-02-15 09:33:01 UTC
Logs attached (but attaching did not flip the status).

Comment 5 Pawel Salek 2006-02-15 22:18:23 UTC
I have a feeling it's is a 64-bit issue: software rendering works just fine on a
Athlon+r300 (but hardware acc does not, see a separate report

Comment 6 Sammy 2006-02-17 14:21:20 UTC
If I start dri on my IBM thinkpad with radeon mobility M10 and start 
glxgears after one rotation the whole computer hangs and need a powerdown.
Happens every single time.
FYI

Comment 7 Mike A. Harris 2006-03-07 01:59:30 UTC
(In reply to comment #6)
> If I start dri on my IBM thinkpad with radeon mobility M10 and start 
> glxgears after one rotation the whole computer hangs and need a powerdown.
> Happens every single time.
> FYI

Which is unrelated to this report, as this bug is reporting software GL
problems on x86_64.  The problem you are having is due to radeon kernel
module problems, and is unrelated to this.  Disable dri in xorg.conf
by commenting out Load "dri", or by removing the radeon kernel module
from your system and the problem should go away.  If you have problems,
search bugzilla for other bug that is tracking the radeon problem.



Comment 8 Mike A. Harris 2006-03-07 08:29:32 UTC
Pawel,

Does this problem still occur for you with software rendering on SiS/x86_64
with current Fedora development?

Comment 9 Pawel Salek 2006-03-07 08:39:29 UTC
Affirmative:
$ LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  144 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  17
  Current serial number in output stream:  17

Comment 10 Mike A. Harris 2006-06-27 17:47:28 UTC

*** This bug has been marked as a duplicate of 190245 ***


Note You need to log in before you can comment on or make changes to this bug.