Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 18092 - Anaconda generates exception on symlinks
Summary: Anaconda generates exception on symlinks
Keywords:
Status: CLOSED DUPLICATE of bug 13071
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
: 22302 55308 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-02 14:24 UTC by CaptBrando
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-10-04 18:23:08 UTC


Attachments (Terms of Use)

Description CaptBrando 2000-10-02 14:24:27 UTC
I submitted this bug before, but now have more information.  Anaconda will 
generate an exception when looking for packages to upgrade when the 
following conditions are true.

/home is a symlink to /usr/home.

the FSTab reads as follows.

/dev/hdc1       /usr                    ext2    defaults,usrquota       1 1
/dev/hda3       /home/ftp/pub/rh    ext2    defaults                1 1

Anaconda yaks because the /dev/hda3 device is not mounted 
to /usr/home/ftp/pub/rh.  Once that is changed, anaconda works 
flawlessly.  IMHO, anaconda should not barf on an incorrectly configured, 
yet functional, /etc/fstab.

Let me know if you have any other questions!

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in 
run
    rc = apply (step[1](), (dir,) + step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in 
__call__
    todo.upgradeFindPackages (root)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 928, in 
upgradeFindPackages
    self.fstab.mountFilesystems (self.instPath)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 708, in 
mountFilesystems
    iutil.mkdirChain(instPath + mntpoint)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 193, in 
mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 17] File exists: '/mnt/sysimage/home'

Local variables in innermost frame:
which: 4
dir: /mnt/sysimage/home/ftp/pub/rh
elements: ['', 'mnt', 'sysimage', 'home', 'ftp', 'pub', 'rh']
path: /mnt/sysimage/home

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2000-10-04 18:23:06 UTC
Related to bug 5034.

Comment 2 Michael Fulbright 2000-10-06 16:25:38 UTC

*** This bug has been marked as a duplicate of 13071 ***

Comment 3 Brent Fox 2001-04-14 20:23:53 UTC
*** Bug 22302 has been marked as a duplicate of this bug. ***

Comment 4 Brent Fox 2001-10-29 16:20:20 UTC
*** Bug 55308 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.