Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 180416 - Inconsistent Font used in Korean installation
Summary: Inconsistent Font used in Korean installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: freetype
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: 171491 FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-08 00:26 UTC by Jong Bae KO
Modified: 2008-08-02 23:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-01 09:49:13 UTC


Attachments (Terms of Use)
two of korean char are not bold (deleted)
2006-02-08 00:29 UTC, Jong Bae KO
no flags Details
embolden font on firefox (deleted)
2006-02-14 02:35 UTC, sangu
no flags Details
embolden bug (deleted)
2006-07-18 03:13 UTC, sangu
no flags Details
screenshot on vmware. (deleted)
2006-08-01 09:41 UTC, Akira TAGOH
no flags Details
freetype embolden bug still happens (deleted)
2006-12-10 01:46 UTC, sangu
no flags Details

Description Jong Bae KO 2006-02-08 00:26:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
see screenshot
two of korean char is not bold.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.change the font
2.
3.
  

Additional info:

Comment 1 Jong Bae KO 2006-02-08 00:29:20 UTC
Created attachment 124344 [details]
two of korean char are not bold

Comment 2 sangu 2006-02-14 02:35:49 UTC
Created attachment 124592 [details]
embolden font on firefox

This is embolden option( bug 168297 )bug, maybe.

See Also :
http://bbs.kldp.org/download.php?id=4816&sid=508caa83eeeae30c96bf04f50f2381e9

Comment 3 David Cantrell 2006-02-22 19:23:46 UTC
The /usr/share/fonts/korean/TrueType/gulim.ttf file was missing from stage2.img.
 Corrected in CVS.

Comment 4 David Cantrell 2006-02-22 19:40:35 UTC
Can't copy gulim.ttf to stage2.img.  It's too big.  dotum.ttf will need to have
this glyph added.

Comment 6 Leon Ho 2006-03-06 01:17:41 UTC
The styles within both fonts are different, we probably need another solution. 

llch->jko
But first, John, can you type that character into a text file (using gedit) and
send attach it to here? We need its unicode codepoint first.

Comment 7 Leon Ho 2006-03-06 01:46:22 UTC
U+D658 is the character (using 2bul IM, type "ghks"). 

I have also found that glyph in Dotum - So it is not an issue on missing glyph
in the font.

So confirm it maybe as sangu said, an embolden bug.

Comment 9 Leon Ho 2006-07-13 05:27:20 UTC
*** Bug 197031 has been marked as a duplicate of this bug. ***

Comment 10 Akira TAGOH 2006-07-18 02:50:25 UTC
This looks fine with fontconfig-2.3.95-4.1.1, freetype-2.2.1-2.1 and
gedit-2.15.4-1. also works fine on firefox with news.naver.com where was used to
take a screenshot. please double-check this.

Comment 11 sangu 2006-07-18 03:13:22 UTC
Created attachment 132581 [details]
embolden bug

Increase text size (ctrl+ +)
This problem still happens in embolden using font.

fontconfig-2.3.95-4.1.1
freetype-2.2.1-2.1
firefox-1.5.0.4-3

Comment 12 Akira TAGOH 2006-07-18 04:12:13 UTC
(In reply to comment #11)
> Created an attachment (id=132581) [edit]
> embolden bug
> 
> Increase text size (ctrl+ +)
> This problem still happens in embolden using font.
> 
> fontconfig-2.3.95-4.1.1
> freetype-2.2.1-2.1
> firefox-1.5.0.4-3
> 

do you have .fonts.conf on your home directory, which probably has any
configuration to enable the bitmap font? apparently it looks like you are using
a bitmap font for displaying. and how about this on gedit with specifying the
font in the preference say?


Comment 13 Akira TAGOH 2006-08-01 09:41:14 UTC
Created attachment 133383 [details]
screenshot on vmware.

I just tried to install rawhide from rawhide-20060731 tree on Korean. and took
a screenshot on the same page where the original reporter took it. it looks
good.

Comment 14 Akira TAGOH 2006-08-01 09:49:13 UTC
So it works fine for me with the latest Korean fonts, and I couldn't even
reproduce on other applications. so closing this bug. please reopen this with
the certain information to reproduce this if someone still enconters this issue.

Thanks

Comment 15 sangu 2006-12-10 01:46:35 UTC
Created attachment 143229 [details]
freetype embolden bug still happens

Please See : https://bugzilla.novell.com/show_bug.cgi?id=158573
This problem still happens. 
please Reopen!!!!


Note You need to log in before you can comment on or make changes to this bug.