Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 180281 - Mirror synchronization progress bar missing
Summary: Mirror synchronization progress bar missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact:
URL:
Whiteboard:
Depends On: 195392
Blocks: 159457 181409
TreeView+ depends on / blocked
 
Reported: 2006-02-06 21:26 UTC by Nate Straz
Modified: 2009-04-16 23:12 UTC (History)
1 user (show)

Fixed In Version: RHBA-2006-0528
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-10 21:52:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0528 normal SHIPPED_LIVE system-config-lvm bug fix update 2006-08-10 04:00:00 UTC

Description Nate Straz 2006-02-06 21:26:11 UTC
Description of problem:

As stated in bz 159457, a progress bar is supposed to show up somewhere
after a mirror is created to show the progress of the mirror synchronization.
I do not see a progress bar anywhere.

Version-Release number of selected component (if applicable):
system-config-lvm-1.0.9-1.0

How reproducible:
Every time

Steps to Reproduce:
1. Create mirror volume
2. Run `lvs` on the command line to verify synchronization
3. Look for progress bar in system-config-lvm
  
Actual results:

No progress bar found

Expected results:
A progress bar should be visible when viewing the mirror.

Additional info:

Comment 1 Stanko Kupcevic 2006-02-14 22:05:42 UTC
Fixed in 1.0.14

Comment 4 Nate Straz 2006-07-05 21:41:26 UTC
The GUI becomes unusable after a mirror create because the lvcreate command
waits for the mirror to sync before returning, bz 195392.  The "Creating Logical
Volume" progress bar bounced back and forth so the GUI itself is not "hung," but
it isn't usable until the lvcreate command completes, which can take a very long
time.

Comment 5 Nate Straz 2006-07-05 22:12:04 UTC
lvcreate doesn't exit even when the mirror sync completes.

Comment 6 Stanko Kupcevic 2006-07-06 15:50:59 UTC
It used to be that lvcreate would return immediately, and sync'ing would
continue in the background. 

Investigating...


Comment 7 Nate Straz 2006-07-06 22:19:52 UTC
This is verified to work w/ lvm2-2.02.06-4.0.RHEL4

Comment 9 Red Hat Bugzilla 2006-08-10 21:52:10 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0528.html



Note You need to log in before you can comment on or make changes to this bug.