Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 180270 - rhn-applet: rpm verify fails due to config files in .spec not marked with %verify
Summary: rhn-applet: rpm verify fails due to config files in .spec not marked with %v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhn-applet
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Robin Norwood
QA Contact: Beth Nackashi
URL:
Whiteboard:
Depends On:
Blocks: 81409 181409
TreeView+ depends on / blocked
 
Reported: 2006-02-06 20:57 UTC by Beth Nackashi
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2006-0472
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-10 21:34:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0472 normal SHIPPED_LIVE rhn-applet bug fix update 2006-08-09 04:00:00 UTC

Description Beth Nackashi 2006-02-06 20:57:18 UTC
+++ This bug was initially created as a clone of Bug #180268 +++

Description of problem:
The TPS rpm --verify tests fail because the /etc/sysconfig/rhn/rhn-applet config
file will always be different from default.  Why?  Because the uuid field gets
populated during the installation process.  The spec file needs to be flagged
with approriate %verify bits so it passes this test.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fanny Augustin 2006-04-11 00:16:45 UTC
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release

Comment 2 Robin Norwood 2006-05-03 21:02:45 UTC
Should be fixed in CVS.

See also: bug #180268

Comment 3 Robin Norwood 2006-05-03 21:13:21 UTC
*** Bug 185697 has been marked as a duplicate of this bug. ***

Comment 6 Beth Nackashi 2006-06-02 20:00:31 UTC
Package tested:
rhn-applet-2.1.25-16

Architectures tested:
i386, ia64, x86_64, s390, s390x, ppc

All had a timestamp change on the config file.  Should timestamp be added to the
list of excludes as well?

[root@test01-ia64 tmp]# rpm -V rhn-applet
........C c /etc/sysconfig/rhn/rhn-applet



Comment 7 Beth Nackashi 2006-06-02 20:07:56 UTC
Hmm.  After further research, I see that this is not timestamp related at all. 
This is some sort of "context" flag.  It means that the context stored in the
file's extended attribute on disk is inconsistent with the file_contexts
configuration.  To fix, run /sbin/restorecon on the file(s) in question.

So, should "context" be added to the list of excludes?  Is that even allowed?

Comment 8 Robin Norwood 2006-06-27 21:58:16 UTC
ok - this has been fixed by adding the following to the %post section:

chcon system_u:object_r:etc_t /etc/sysconfig/rhn/rhn-applet


Comment 9 Beth Nackashi 2006-06-27 22:28:53 UTC
verified on s390, s390x, ppc, ia64, i386, and x86_64 with package
rhn-applet-2.1.25-22

rpm -V now gives empty response

TPS tests *should* pass.  Let's hope so.

Comment 11 Red Hat Bugzilla 2006-08-10 21:34:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0472.html



Note You need to log in before you can comment on or make changes to this bug.