Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 180268 - rhn-applet: rpm verify fails due to config files in .spec not marked with %verify
Summary: rhn-applet: rpm verify fails due to config files in .spec not marked with %v...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhn-applet
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Beth Nackashi
URL:
Whiteboard:
: 185697 (view as bug list)
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2006-02-06 20:55 UTC by Beth Nackashi
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2006-0471
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 15:22:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0471 normal SHIPPED_LIVE rhn-applet bug fix update 2006-07-19 20:49:00 UTC

Description Beth Nackashi 2006-02-06 20:55:06 UTC
Description of problem:
The TPS rpm --verify tests fail because the /etc/sysconfig/rhn/rhn-applet config
file will always be different from default.  Why?  Because the uuid field gets
populated during the installation process.  The spec file needs to be flagged
with approriate %verify bits so it passes this test.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Beth Nackashi 2006-03-16 22:33:56 UTC
To test this:
1- copy the source rpm onto the client
2- rpm2cpio rhn-applet-x.x.xx-4.src.rpm |cpio -i -d
3- open applet.spec
4- look for %verify

Comment 2 Fanny Augustin 2006-04-13 19:56:05 UTC
Moving bugs to the CanFix List

Comment 3 Robin Norwood 2006-05-03 21:02:04 UTC
Should be fixed in CVS now.

Testing notes - see comment #1

Comment 5 Beth Nackashi 2006-05-12 16:43:39 UTC
Verified fix on i386, ia64, x86_64, s390, and ppc64.  I suppose that was
overkill, considering it's a source RPM, but hey.  I had access to the hardware
and decided to take advantage.

Package verified:
rhn-applet-2.1.25-15.src.rpm

Comment 6 Beth Nackashi 2006-06-02 18:58:00 UTC
*** Bug 185697 has been marked as a duplicate of this bug. ***

Comment 8 Red Hat Bugzilla 2006-07-20 15:22:30 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0471.html



Note You need to log in before you can comment on or make changes to this bug.