Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 180117 - gdm password label too narrow for Japanese translation
Summary: gdm password label too narrow for Japanese translation
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-artwork
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-06 03:52 UTC by Jens Petersen
Modified: 2013-03-06 03:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-16 21:49:04 UTC


Attachments (Terms of Use)

Description Jens Petersen 2006-02-06 03:52:52 UTC
Description of problem:
The user/passwd label in the new Fedora Bubble theme is too narrow to display
the Japanese translation of "_Password" in one single line.

Version-Release number of selected component (if applicable):
redhat-artwork-0.235-2

How reproducible:
every time

Steps to Reproduce:
1. Start gdm with Japanese system locale (ja_JP.UTF-8),
   eg after a Japanese install.
2. Username to gdm login.
3. Input password to gdm login.
  
Actual results:
2. "Username(U)" label displays fine.
3. "Passwo
   rd(P)"
is split across a line.

Expected results:
3. "Password(P)"

Additional info:
Could the width of the label please be increased to allow translations to
fit the label width.  This very likely also affects other Asian languages like
Korean, etc, I imagine

Comment 1 Matthias Clasen 2006-02-16 05:26:38 UTC
_very_ visible issue in some locales. moving to blocker for quick investigation.

Comment 2 Matthias Clasen 2006-02-16 15:22:26 UTC
Mo,  do you have an idea here ? Ray and I randomly changed width attributes
in the .xml file, but we were unable to make the box adapt to the changing width
of the label.

Comment 3 Matthias Clasen 2006-02-18 01:18:12 UTC
This should be fixed now. Please test.

Comment 4 Matthias Clasen 2006-02-18 03:39:48 UTC
Needs to be moved from -HEAD.

Comment 5 Matthias Clasen 2006-02-20 16:54:25 UTC
Moved

Comment 6 Jens Petersen 2006-02-27 13:56:46 UTC
Unfortunately I still see the same with 0.240-1.

Comment 7 Jens Petersen 2006-02-27 13:58:23 UTC
My display is 1280x1024 fwiw.

Comment 8 Matthias Clasen 2006-03-01 05:05:48 UTC
ok, so the problem is not the initial size of the box, it is that the box does
not grow to accomodate the larger second label.

Comment 9 Matthias Clasen 2006-03-02 15:52:14 UTC
Related upstream bug: 
http://bugzilla.gnome.org/show_bug.cgi?id=331706

Comment 10 Ray Strode [halfline] 2006-03-07 16:43:35 UTC
We may not get to this for FC5, but it really can't block the release.  Moving
to Target.

Comment 11 Caius Chance 2006-10-11 05:23:36 UTC
FYI, this might possibly be a duplicate of bug #209571.

Comment 12 Caius Chance 2006-10-11 05:24:53 UTC
Please advice current status. Thank you very much.

Comment 13 Jens Petersen 2006-10-16 05:44:36 UTC
I think this is for the FC5 artwork.

Comment 14 Jens Petersen 2006-10-16 21:49:04 UTC
FC5 still has this problem, but closing anyway.


Note You need to log in before you can comment on or make changes to this bug.