Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 180042 - beagle-search fails to start due to gnome-spinner-rest icon missing in default clearlooks theme
Summary: beagle-search fails to start due to gnome-spinner-rest icon missing in defaul...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-icon-theme
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-02-05 00:19 UTC by Ben Steeves
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-08 12:36:09 UTC


Attachments (Terms of Use)

Description Ben Steeves 2006-02-05 00:19:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.1) Gecko/20060202 Fedora/1.5.0.1-2 Firefox/1.5.0.1

Description of problem:
Attempting to start beagle-search from the command line generates the following exception:

Unhandled Exception: GLib.GException: Icon 'gnome-spinner-rest' not present in theme
in <0x000d2> Gtk.IconTheme:LoadIcon (System.String icon_name, Int32 size, IconLookupFlags flags)
in <0x0008d> Search.Spinner:LoadImages ()
in <0x0001a> Search.Spinner:ThemeChanged (System.Object obj, System.EventArgs args)
in (wrapper delegate-invoke) System.MulticastDelegate:invoke_void_object_EventArgs (object,System.EventArgs)
in <0x000c9> GLib.Signal:voidObjectCallback (IntPtr handle, IntPtr gch)
in (wrapper native-to-managed) GLib.Signal:voidObjectCallback (intptr,intptr)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x00008> Gtk.Application:Run ()
in <0x0000c> Gnome.Program:Run ()
in <0x00147> Search.MainWindow:Main (System.String[] args)

If you switch to a different theme, say Bluecurve, beagle-search starts correctly. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select 'Clearlooks' Theme (should be default).
2. Start "beagle-search" from command-line (you can do it via the desktop but you won't see any result that way).

  

Actual Results:  Beagle Search crashes with an unhandled exception.

Expected Results:  Beagle Search should start.

Additional info:

Comment 1 Matthias Clasen 2006-02-05 03:39:59 UTC
More gnome-icon-theme breakage

Comment 2 John (J5) Palmieri 2006-02-06 16:03:53 UTC
Looks like upstream has requested this be fixed so I assume the next
gnome-icon-theme update should fix this.

Comment 3 sangu 2006-02-07 05:04:22 UTC
See Also : http://bugzilla.gnome.org/show_bug.cgi?id=328432

Comment 4 Matthias Clasen 2006-02-07 06:05:26 UTC
Not fixed in 2.13.7 yet; animation directories are missing in index.theme

Comment 5 Matthias Clasen 2006-02-07 19:17:19 UTC
Seems to work for me with the gnome-themes and gnome-icon-theme packages I just
built. Can you try again tomorrow ?

Comment 6 Ben Steeves 2006-02-08 12:36:09 UTC
Looks like it's working now.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.