Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 180004 - kernel unable to re-read partition table on install
Summary: kernel unable to re-read partition table on install
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
: 180005 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-04 14:56 UTC by sjm
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-05 03:47:17 UTC


Attachments (Terms of Use)

Description sjm 2006-02-04 14:56:03 UTC
Description of problem:
The full message:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
  self.intf.icw.nextClicked()
 File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
  rc = apply(func, self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
  diskset.savePartitions ()
 File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
  disk.commit()
error: Warning: The kernel was unable to re-read the partition table 
on /dev/hda (Device or resource busy).  This means Linux won't know anything 
nothing about the modifications you made until you reboot.  You should reboot 
your computer before doing anything with /dev/hda.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install FC4 on Toshiba Satellite P20
2. Choose auto partition
3. choose any packages
  
Actual results:
Bails out after selecting packages

Expected results:
Install FC4


Additional info:
manually partitioning seems to have done the job

Comment 1 Chris Lumens 2006-02-05 03:45:02 UTC
*** Bug 180005 has been marked as a duplicate of this bug. ***

Comment 2 Chris Lumens 2006-02-05 03:47:17 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.