Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 179807 - scim stops working after reloading configuration
Summary: scim stops working after reloading configuration
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: scim
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 165655 SCIM
TreeView+ depends on / blocked
 
Reported: 2006-02-03 02:10 UTC by Lawrence Lim
Modified: 2014-03-26 00:53 UTC (History)
2 users (show)

Fixed In Version: scim-1.4.4-9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-14 14:11:10 UTC


Attachments (Terms of Use)

Description Lawrence Lim 2006-02-03 02:10:56 UTC
Description of problem:
Input with scim does not work anymore, irregardless of which other IME
installed, after refresh/restart the IME in the aux.

Version-Release number of selected component (if applicable):
scim-1.4.2-9
scim-chewing-0.2.1-4
libchewing-0.2.7-1.1

How reproducible:
Always

Steps to Reproduce:
1.start gedit with zh_TW locale
2.start scim and select chewing IME
3.right click on chewing's aux window
4. select the second optiont to refresh the IME  

Actual results:
scim fail to function anymore

Expected results:
scim should not fail

Additional info:

Comment 1 Lawrence Lim 2006-02-03 11:22:19 UTC
I thought I narrowed down to scim-chewing as pinyin seems ok for me. Tagoh-san
noticed this happend in all locale for all IME. Hence, raising the serverity due
to the scope of impact. 

To get SCIM to work again, simply start a new gtk application has to start and
that will cause SCIM to start in the background.

Another interesting issue is that after scim stopped, scim-setup (config dialog)
doesn't accept of any changes that has made on that then. This could be right as
scim is stopped. But the strange thing is that ctrl-SPACE still work. Hence, the
aux window for the IME still functional. However, all input is display as ASCII
even though the IME seems to be switched on.



Comment 2 Jens Petersen 2006-02-03 14:14:52 UTC
Dropping scim-reload-engines-165655.patch in scim-1.4.4-2.

Comment 4 A S Alam 2006-03-14 16:49:38 UTC
tested with:
scim-1.4.4-9
scim-chewing-0.2.1-5.1
libchewing-0.2.7-1.2.1

scim works fine after change configuration and then reload this


Note You need to log in before you can comment on or make changes to this bug.