Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 179522 - embedded_bitmap patch erroneously got dropped when Xorg went modular
Summary: embedded_bitmap patch erroneously got dropped when Xorg went modular
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libXft
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-02-01 02:16 UTC by sangu
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-03 22:37:48 UTC


Attachments (Terms of Use)
patch to current spec file (deleted)
2006-02-02 06:08 UTC, Tim Mayberry
no flags Details | Diff
patch to support embeddedbitmap fontconfig option (deleted)
2006-02-02 06:10 UTC, Tim Mayberry
no flags Details | Diff
Screenshot of application without patch. (deleted)
2006-02-02 06:12 UTC, Tim Mayberry
no flags Details
Screenshot of application with patch. (deleted)
2006-02-02 06:13 UTC, Tim Mayberry
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 5808 None None None Never

Description sangu 2006-02-01 02:16:10 UTC
Description of problem:
Please See bug 164374

KDE and mozilla(and epiphany, yelp, devhelp, liferea) use libXft.

Version-Release number of selected component (if applicable):
2.1.8.2-2

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Ray Strode [halfline] 2006-02-01 03:08:37 UTC
So just to be clear, a patch to Xft that was applied to the modular Xorg tree
didn't make it through the modular transition.  bug 164374 fixes gtk apps
because gtk apps use cairo now instead of Xft for text rendering, but the old
patch needs to be added back to xft (now in the libXft package) for things to
look good in KDE and mozilla.

Comment 2 Mike A. Harris 2006-02-01 08:13:52 UTC
Does anyone know why this patch is not part of the upstream libXft
proper?

Comment 3 Tim Mayberry 2006-02-02 03:30:19 UTC
It looks as though there is a patch relevant to this in the upstream tracker
https://bugs.freedesktop.org/show_bug.cgi?id=1579 but there hasn't been any
activity on that bug in a fair while. Only a small part of that patch is
relevant to embedded bitmaps so I've created a new patch and I'm in the process
testing it.

As far as upstream goes, as soon as I can verify that the patch is ok I'll
submit the same patch against cvs head in the upstream tracker and see what the
response is.

Comment 4 Tim Mayberry 2006-02-02 06:08:31 UTC
Created attachment 124031 [details]
patch to current spec file

Comment 5 Tim Mayberry 2006-02-02 06:10:54 UTC
Created attachment 124032 [details]
patch to support embeddedbitmap fontconfig option

A patch for libXft so that the fontconfig embeddedbitmap option is supported.

Comment 6 Tim Mayberry 2006-02-02 06:12:58 UTC
Created attachment 124033 [details]
Screenshot of application without patch.

Just a screenshot to show what the result of this patch is.

Comment 7 Tim Mayberry 2006-02-02 06:13:49 UTC
Created attachment 124034 [details]
Screenshot of application with patch.

Comment 8 Mike A. Harris 2006-02-03 11:51:06 UTC
Please submit the patch to upstream X.Org bugzilla for review.  Once it
has been reviewed and accepted upstream, and committed into CVS, we'll
reconsider adding it to a future FC libXft build.

Thanks in advance.

Comment 9 Mike A. Harris 2006-03-07 12:35:16 UTC
Once upstream maintainers have released Xft with this support built in, we
will include it in a future OS release, and may consider it as a Fedora
update also.

Comment 10 sangu 2007-02-15 03:48:11 UTC
Please See : https://bugs.freedesktop.org/show_bug.cgi?id=5808

Doesn't libxft have maintainer?

Comment 11 Adam Jackson 2007-05-03 22:37:48 UTC
Tracking this upstream.


Note You need to log in before you can comment on or make changes to this bug.