Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 179468 - Firefox no longer remembers passwords
Summary: Firefox no longer remembers passwords
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-01-31 16:54 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-06 02:13:11 UTC


Attachments (Terms of Use)

Description Ivan Gyurdiev 2006-01-31 16:54:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20060126 Fedora/1.5-5 Firefox/1.5

Description of problem:
Firefox doesn't remember my passwords anymore.
This is a rawhide system with everything installed, x86_64.
The browser is set to:
- remember passwords
- clear private data on exit
- passwords are not selected to be cleared, everything else is

This is a regression.

I can see my hashed passwords in signons.txt, but I can't access any of them via "Saved Passwords".

Also, I am no longer prompted if I want to remember the password (at least not on sites that I already have passwords remembered, haven't tested new ones)

Version-Release number of selected component (if applicable):
firefox-1.5-5

How reproducible:
Always

Steps to Reproduce:
--

Additional info:

Comment 1 Ivan Gyurdiev 2006-02-21 10:13:45 UTC
Reconfirming bug on rawhide today:
firefox-1.5.0.1-3



Comment 2 Matthias Clasen 2006-02-25 04:44:02 UTC
Chris, any progress on this ? selinux ?

Comment 3 Ivan Gyurdiev 2006-02-26 01:11:32 UTC
This has recently started working on some web pages, but it still can't defeat
bugzilla pages, and Red Hat Bugzilla in particular.

I run selinux in permissive mode all the time, so it shouldn't cause any harm.

Comment 4 Christopher Aillon 2006-02-26 02:02:54 UTC
I tested this on bugzilla.redhat.com and it seemed to work for me.... are you
using the latest nspr/nss packages as well?

Comment 5 Ivan Gyurdiev 2006-02-26 02:25:01 UTC
Well, it doesn't even ask me if I want the password remembered.

By the way, on the sites that it does work on, I see the passwords are now saved
and shown in "Saved Passwords". However, it's not nice that all the ones I had
saved before are not accessible. This also happened with my bookmarks - at some
point they were all erased during an upgrade.

I am currently using:
nspr-4.6.1-2.2
nss-3.11-4


Comment 6 Christopher Aillon 2006-02-26 08:07:08 UTC
Interesting ... could the sites have added autocomplete="OFF" to their forms
since you saved them?  Do they work properly if you

killall firefox
mv ~/.mozilla ~/.mozilla.bak



Comment 7 Ivan Gyurdiev 2006-02-26 15:37:04 UTC
Yes, the sites work correctly from a fresh mozilla install.

However, when using my current .mozilla folder, they do ask to save the
password, and they are not listed in "Password Never Saved" (or "Saved
Passwords", even though I had accumulated a lot of passwords).


Comment 8 Christopher Aillon 2006-03-01 18:17:02 UTC
Hm, I'm not sure what the problem is -- I haven't heard of this and I certainly
can't reproduce.  It could possibly be an issue with your profile becoming
somehow corrupted.

Comment 9 Ivan Gyurdiev 2006-03-02 23:24:26 UTC
Well if you have no interest in pursuing this further that's fine with me...

Can you let me know how to un-corrupt the folder without losing the rest of my
settings (i.e. which files are relevant to password settings, so I can delete
only those).



Comment 10 Christopher Aillon 2006-10-06 02:13:11 UTC
There's no really good way to uncorrupt it, unfortunately.  Seeing how this is a
one-off and no way of fixing this, really, going to close it.


Note You need to log in before you can comment on or make changes to this bug.