Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 179158 - Installer crashes in post-install
Summary: Installer crashes in post-install
Keywords:
Status: CLOSED DUPLICATE of bug 139146
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: James Laska
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-27 20:43 UTC by Soren Juelsgaard
Modified: 2013-09-02 06:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-28 01:31:13 UTC


Attachments (Terms of Use)
anaconda text dump (deleted)
2006-01-27 20:46 UTC, Soren Juelsgaard
no flags Details

Description Soren Juelsgaard 2006-01-27 20:43:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:

The installer crashes in the post install with the following message:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 1204, in doPostInstall
    stdout = devnull)
  File "/usr/lib/anaconda/iutil.py", line 53, in execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/sbin/kudzu can not be run


Please see attached anaconda dump.

I have tried with two different hard drives - one SATA and one EIDE.
I have tried minimum installs and "everything" installs.
I have tried automatic Druid partitioning of disks, I have tried manual Druid, I have tried fdisk partitioning.

I am not sure if this bug is related to bug #170003

I find it curious that the text install has all the error messages from rpmdb ("rpmdb: PANIC: fatal region error detected: run recovery").



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start CD install
2a. pick graphic install
3a. watch in tears how the post-install crashes
or
2b. pick text-mode install
3b. installer crashes with "rpmdb: PANIC: fatal region error detected: run recovery" spewing all over the screen while installing packages.
  

Additional info:

Comment 1 Soren Juelsgaard 2006-01-27 20:46:12 UTC
Created attachment 123792 [details]
anaconda text dump

Comment 3 Soren Juelsgaard 2006-01-27 22:32:42 UTC
My system is a P4 1.7GHz system, and I believe that it is a copy of an older FC3
bug: #139146


Comment 4 Chris Lumens 2006-01-28 01:31:13 UTC

*** This bug has been marked as a duplicate of 139146 ***


Note You need to log in before you can comment on or make changes to this bug.