Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 178987 - Partioning 3 sata hardrives either raid or not gives error
Summary: Partioning 3 sata hardrives either raid or not gives error
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2006-01-26 01:22 UTC by Jkjgt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-01-28 05:43:53 UTC

Attachments (Terms of Use)

Description Jkjgt 2006-01-26 01:22:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050603 Fedora/1.7.8-1.2.1.legacy

Description of problem:
System AMD 64 venice3200+ MSI k8ngm2-fid 2x512MB 3 250GB sata HD seagate ASUS DVD burner

Was able to format last week successfully with 2 drives some issues with ethernet and audio driver not resolved (was short a sata power cable so tested on 2 drives) Power cable arrived tried to reload with all 3 drives and now have persistant and repeatable problem.  I am currently trying to load all of linux4 perviously only took workstation entries (was testing only now trying for real).

Version-Release number of selected component (if applicable):
Fedora4 iso discs from website passed mediacheck

How reproducible:

Steps to Reproduce:
1.start fedora4 disks
2.load nvidia sata driver
3.once preparing to load entire contents of linux comes back with the following

Actual Results:  I hope this is accurate  had to write it by hand.
traceback (most recent call last);
File "/usr/lib/anaconda/", line 1137, in handleRenderCallback
File "usr/lib/anaconda/iw/", line 244, in renderCallback
File "/usr/lib/anaconda/", line 873, in nextclicked
File "/usr/lib/anaconda/", line 174, in gotoNext
File "/usr/lib/anaconda/", line 242, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/", line 579, in turnOnFilesystems
diskset.savePartitions ()
File "/usr/lib/anaconda/", line 726, in savePartitions
error: Error: Error informing the kernel about modifications to partion /dev/sdb1 - Device or resource busy. This means Linux won't know about any changes you made to /dev/sdb1 until you reboot- so you shouldn't mount it or use it in any way before rebooting

Expected Results:  clean load

Additional info:

This occured while trying to partition in Raid 5 then duplicated as Raid 0, and standard load JBODs.  Scratching my head.  Your wisdom would be most appreciated.  Thanks.

Comment 1 Jkjgt 2006-01-26 02:11:58 UTC
Hi All,
   New find that may help track this down.  The new drive I added was added as
the   primary drive on the 2nd SATA device for this board.  I was wondering if
that had anything to do with anything, so transfered the new drive to the
secondary drive on the 1st SATA device for the board. I then proceeded to repeat
the procedure above but this time it appears to be working.  I tried the auto
setting which looked like it worked and now restarted and am installing as Raid
(1 for /boot, 0 for swap and 5 for / and /home).  It appears to be going well. 
So if I were to guess I would say that somehow having the 2 drives previously
formated and adding the 3rd drive on the primary of the 2nd SATA somehow fooled
something.  Hope this helps.  If I learn anything more I will post.

Comment 2 Jkjgt 2006-01-27 00:08:12 UTC
Looks like I spoke too soon.  After waiting 24 hours I was still waiting for the
raid array to format.  Seems unlikely that this is a reasonable wait period even
for raid 5.   I am guessing this may have something to do with the bug.  Please
advise if you have any ideas.

Comment 3 Jkjgt 2006-01-27 01:08:13 UTC
Latest news,
Tried to restart install and am getting the same error messages.  

Comment 4 Jeremy Katz 2006-01-28 05:43:53 UTC

*** This bug has been marked as a duplicate of 160693 ***

Comment 5 Jkjgt 2006-01-28 16:40:06 UTC
Hi Jeremy, 
   I took a look at 160693 and hate to admit I am so much of a noob that I am
not sure how to correct the version of anaconda that exists on my distro.  Is
there a corrected version I could use?  I could not find reference to it in the
thread listed.  Is there some reference as to how to patch the existing one?

Note You need to log in before you can comment on or make changes to this bug.