Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 178920 - pxe network install firstboot BootWindow myVbox
Summary: pxe network install firstboot BootWindow myVbox
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firstboot
Version: 4.0
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
: 158567 (view as bug list)
Depends On:
Blocks: 189992
TreeView+ depends on / blocked
 
Reported: 2006-01-25 14:26 UTC by Markus Walther
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0307
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-01 22:50:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0307 normal SHIPPED_LIVE firstboot bug fix update 2007-04-30 14:36:21 UTC

Description Markus Walther 2006-01-25 14:26:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; SV1; .NET CLR 1.1.4322)

Description of problem:
I do a network installation (with pxe boot, installation over nfs and kickstart). When the server boots the first time (after the installation) the following bug is reported:

***

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 502, in loadModules
    vbox, pix, title = module.launch()
  File "/usr/src/build/430918-x86_64/install/usr/share/firstboot/modules/boot_gui.py", line 177, in launch
    return FirstbootGuiWindow.launch(self)
  File "/usr/lib64/python2.3/site-packages/rhpl/firstboot_gui_window.py", line 106, in launch
    internalVBox.pack_start(self.myVbox, gtk.TRUE)
AttributeError: BootWindow instance has no attribute 'myVbox'

***

Then I can finish the installation and all works fine, so far i can see!



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. pxe boot
2. network install over nfs
3. use kickstart for configuration
4. after installation and the first reboot the bug above is reported
  

Additional info:

Comment 2 Chris Lumens 2006-02-27 20:30:05 UTC
*** Bug 158567 has been marked as a duplicate of this bug. ***

Comment 7 Kimball Murray 2006-08-28 16:48:33 UTC
I just updated BZ 158567.  Not sure whether that bug or this is being used to
track new information related to this problem.


Comment 8 Chris Lumens 2006-09-20 20:01:00 UTC
This code is actually in rhpl in RHEL-4.

Comment 9 Chris Lumens 2006-10-06 17:25:31 UTC
Though that errata has already gone out so it's too late to fix this there, but
it's simple enough to deal with in firstboot.

Comment 17 Red Hat Bugzilla 2007-05-01 22:50:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0307.html



Note You need to log in before you can comment on or make changes to this bug.