Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 178805 - yum doesn't read the 'proxy' repo option in config file
Summary: yum doesn't read the 'proxy' repo option in config file
Keywords:
Status: CLOSED DUPLICATE of bug 161190
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-24 15:18 UTC by Hugo Cisneiros
Modified: 2014-01-21 22:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-24 15:26:13 UTC


Attachments (Terms of Use)

Description Hugo Cisneiros 2006-01-24 15:18:10 UTC
Description of problem:

- When separating local and external repositories, the manpage says that you
should put an 'proxy' option with the value '_none_' to *not* use a proxy for a
specific repository (or skip global configuration proxy option). But even
specifying the option, yum tries to use the proxy (with environment variables
http_proxy and ftp_proxy configured). This way one cannot separate specific
local repositories (intranet) and external repositories (external throught a proxy).

Version-Release number of selected component (if applicable):

- yum-2.4.1-1.fc4

How reproducible:

Steps to Reproduce:
1. Configure yum to use a proxy to get files.
2. Set an 'proxy=none' (or _none_? see manpage) in a repo file (.repo)
3. Try to 'yum update' and see if it's coming throught proxy or not (strace is
your friend too)
  
Actual results:

yum gets the files of that specific repo throught proxy. If the proxy is
unavailable for a local repo, it fails to downloads the files.

Expected results:

yum ignores the proxy and tries to get the files directly.

Additional info:

Comment 1 Hugo Cisneiros 2006-01-24 15:26:13 UTC
I found another entry in Bugzilla with this problem:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161190

But in this case, it is specific to the 'none' proxy option. Don't know it's a
duplicate entry. I think it is some kind of duplicate, but with more information
to add about the problem. Correct me if I'm wrong, but I'll try to Mark as
duplicate ;) Sorry.

*** This bug has been marked as a duplicate of 161190 ***


Note You need to log in before you can comment on or make changes to this bug.