Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 178635 - Describe problem, fix, or request for release notes
Summary: Describe problem, fix, or request for release notes
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL: http://fedoraproject.org/wiki/DocsPro...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-22 21:02 UTC by Eugene Chudakov
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-23 03:44:01 UTC


Attachments (Terms of Use)
anacdump.txt file produced by crashing anaconda (written to a floppy) (deleted)
2006-01-22 21:02 UTC, Eugene Chudakov
no flags Details

Description Eugene Chudakov 2006-01-22 21:02:13 UTC
Description of problem, bug, incorrect information, or enhancement request:

Anaconda crashes persistently while installing FC4, before it starts
formatting. I have FC2 installed on this desktop, with software RAID.
I was trying the "custom" installation. 
Before the crash it complains about hdg5 (a part of md5). I did not include
a mount point for md5. I enclose here the traceback and attach the whole
file anacdump.txt

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
    diskset.savePartitions ()
  File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
    disk.commit()
error: Error: Error informing the kernel about modifications to partition
/dev/hdg5 - Device or resource busy.  This means Linux won't know about any
changes you made to /dev/hdg5
until you reboot - so you shouldn't mount it or use it in any way before rebooting.
                                                                               
                                                                               
                    
Version of release notes this bug refers to:

Fedora Core 4 final release

Comment 1 Eugene Chudakov 2006-01-22 21:02:13 UTC
Created attachment 123548 [details]
anacdump.txt file produced by crashing anaconda (written to a floppy)

Comment 2 Rahul Sundaram 2006-01-22 21:21:29 UTC
Thank you for the bug report but this should be filed against Anaconda and not
against the release notes since the release notes. Reassigning to Anaconda. 

Comment 3 Chris Lumens 2006-01-23 03:44:01 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.