Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 178529 - Deprecation warnings when booting up
Summary: Deprecation warnings when booting up
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
: 183990 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-01-21 12:26 UTC by Reuben Farrelly
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 11.2.0.6-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-23 19:22:13 UTC


Attachments (Terms of Use)

Description Reuben Farrelly 2006-01-21 12:26:51 UTC
These warnings are logged to the console when launching a rescue disk image
based on FC5test2:

md: anaconda(pid 581) used deprecated START_ARRAY ioctl. This will not be
supported beyond July 2006   [twice]

SGI XFS Quota Management subsystem
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
program anaconda is using a deprecated SCSI ioctl, please convert it to SG_IO
program anaconda is using a deprecated SCSI ioctl, please convert it to SG_IO
program anaconda is using a deprecated SCSI ioctl, please convert it to SG_IO
[quite a few times]

To see these I simply booted up the rescue image, and then ran  dmesg -s100000 |
less  and scrolled back.

Comment 1 Thomas M Steenholdt 2006-01-22 07:23:52 UTC
Yup, noticed this too and it really should be fixed...

Comment 2 Chris Lumens 2006-03-04 18:21:12 UTC
*** Bug 183990 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2007-02-23 19:22:13 UTC
Jeremy fixed this late late year.


Note You need to log in before you can comment on or make changes to this bug.