Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 178177 - xmkmf/imake don't set config file for Imake.tmpl properly
Summary: xmkmf/imake don't set config file for Imake.tmpl properly
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: imake
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target 178656
TreeView+ depends on / blocked
 
Reported: 2006-01-18 10:48 UTC by Axel Thimm
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-07 05:49:24 UTC


Attachments (Terms of Use)
Imakefile for which xmkmf -a fails (deleted)
2006-01-18 10:48 UTC, Axel Thimm
no flags Details
update patch to replace original xorg-cf-files-1.0.0-redhat.patch (deleted)
2006-01-25 04:38 UTC, Akira TAGOH
no flags Details | Diff

Description Axel Thimm 2006-01-18 10:48:48 UTC
Description of problem:
Building nxviewer fails with

+ xmkmf -a
imake -DUseInstalled -I/usr/share/X11/config
make Makefiles
making Makefiles in nxviewer...
make[1]: Entering directory `/BUILD/nx-1.5.0/nxviewer'
Imakefile.c:34: error: Imake.tmpl: No such file or directory
imake: Exit code 1.
  Stop.

I also tried
imake -DUseInstalled -I/usr/share/X11/config
directly and the resulting Makefile has no references at all to
/usr/share/X11/config

Version-Release number of selected component (if applicable):
imake-1.0.0-4

How reproducible:
always

Steps to Reproduce:
1.Untar nxviewer-1.5.0-15.tar.gz
2.xmkmf -a
3.
  
Actual results:
see above

Expected results:
Makefile should know where Imake.tmpl is.

Additional info:
I'm attaching the Imakefile for which xmkmf -a fails.

Comment 1 Axel Thimm 2006-01-18 10:48:48 UTC
Created attachment 123367 [details]
Imakefile for which xmkmf -a fails

Comment 2 Akira TAGOH 2006-01-25 04:36:55 UTC
I have also experienced similar problem with Canna that uses xmkmf to generate
Makefile. the problem is that imake generates Makefile with the wrong path for
imake. it's referring to /usr/lib/X11/config but not /usr/share/X11/config.

Comment 3 Akira TAGOH 2006-01-25 04:38:07 UTC
Created attachment 123648 [details]
update patch to replace original xorg-cf-files-1.0.0-redhat.patch

Comment 4 Axel Thimm 2006-02-21 13:09:57 UTC
Akira's patch fixed the issue for me (thanks!), I tested the nx builds against
the patched up imake on FC5 test3.

Comment 5 Rob van Nieuwkerk 2006-03-05 02:08:53 UTC
The added:

    "# define ConfigDir     /usr/share/X11/config"

in Akira's patch made it possible for me to compile my
old fvwm-1.24r SRPM too (don't ask .. :-).

I added this line by hand to the "xorg-cf-files-1.0.1-redhat.patch"
from rawhide's "imake-1.0.1-2.src.rpm".

Without this fix I get the

    "Imakefile.c:34: error: Imake.tmpl: No such file or directory"

problem too.

Comment 6 Mike A. Harris 2006-03-07 00:36:08 UTC
Fixed in imake-1.0.1-3


Note You need to log in before you can comment on or make changes to this bug.