Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 177502 - gnome-session splash screen displays uninitialized memory.
Summary: gnome-session splash screen displays uninitialized memory.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
: 177574 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-01-11 10:32 UTC by Kjartan Maraas
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-12 07:36:44 UTC


Attachments (Terms of Use)

Description Kjartan Maraas 2006-01-11 10:32:50 UTC
Description of problem:
Lately I've seen some strange things with the shaped splash screen when I log in
. It doesn't happen every time and while I'm not 100% certain I think it only
happened with gdmflexiserver so far.

What I see is that the splash screen is "surrounded" by a left over image of the
boot screen (the black background with services starting and [OK] messages etc)

Not sure this is the right component, but it's the closest I could think of.

This is all rawhide from yesterday.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Nalin Dahyabhai 2006-01-11 21:19:18 UTC
I also see this, but I'm using the "nv" driver.  Perhaps it isn't driver-specific?

Comment 2 Dave Jones 2006-01-11 21:34:32 UTC
*** Bug 177574 has been marked as a duplicate of this bug. ***

Comment 3 Ray Strode [halfline] 2006-01-11 21:38:43 UTC
the splash screen is probably just shaping the window after the window is mapped.

Comment 4 Ray Strode [halfline] 2006-01-12 07:36:44 UTC
Things were getting hosed when gnome-settings-daemon got started and switched
the desktop to use the user's theme (which caused the splash window's style and
shape to get reset)

Should be fixed in tomorrow's rawhide.


Note You need to log in before you can comment on or make changes to this bug.