Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 177362 - XKB map for keyboard cz and variant qwerty does not work
Summary: XKB map for keyboard cz and variant qwerty does not work
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xkbdata
Version: rawhide
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
: 178892 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
Reported: 2006-01-10 02:15 UTC by Milan Kerslager
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-02-24 11:06:54 UTC

Attachments (Terms of Use)

System ID Priority Status Summary Last Updated 5077 None None None Never

Description Milan Kerslager 2006-01-10 02:15:15 UTC
I have FC5 test1 and I tryed to update to the latest development tree. When I'm
trying to use czech keyboard mapping, the error occur with a question to report
this bug. Error when trying to activate XKB settings:

# xprop -root | grep XKB
_XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "us,cz_qwerty", ",",
_XKB_RULES_NAMES(STRING) = "xorg", "pc105", "us,cz_qwerty", "",

# gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
 layouts = [us,cz       qwerty]
 model =
 overrideSettings = true
 options = []

Comment 1 Milan Kerslager 2006-01-11 01:00:01 UTC
I tryed today updates with no luck (I added Czechia qwerty keyboard mappings
from the keymap applet inside Gnome). This is the output of the error message:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
The X.Org Foundation

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

Comment 2 Milan Kerslager 2006-01-14 17:10:16 UTC
I updated FC5 test1 machine today with no luck again. When trying to add
'Czechia/qwerty' keymap, the same error occur still. Some keymaps works though.

Comment 3 Milan Kerslager 2006-01-21 21:26:19 UTC
In FC5test2 I see Czech keyobard as active in the XKB applet (in Gnome) after
the install, but the keymap is actually English. When trying to put second
keymap to the XKB config (through XKB applet in Gnome), the same error occur as
I wrote above about FCtest1. I see an error when trying to use 'setxkbmap cs' on
the command line.
I'm not able to update to the latest devel tree as there is some inconsitency on
the FC download server (I commented out the mirror list and tryed to update from
the main FC server).

Comment 4 Mike A. Harris 2006-01-31 18:52:55 UTC
*** Bug 178892 has been marked as a duplicate of this bug. ***

Comment 5 Milan Kerslager 2006-02-01 13:44:40 UTC
I found that control-center (latest 2.13.90-1 has been builded at Jan 30) is
incorrectly trying to set Czech keymap to 'cs*' even the names of keymaps in has been updated to 'cz*'. This is correct as 'cs' is historic relict and
we are using 'cz' for our language for more than one decade. Please fix or
regenerate appropriate keymap table in control-center application. Thank you.

This is possible that Anaconda has the same problem too...

Comment 6 Milan Kerslager 2006-02-01 13:52:35 UTC
The cz_qwerty variant does not work even cz keymap works. Sorry for the mistake.
The control-center is correct... Changing component to xorg-x11-xkbdata-1.0.1-1.

Comment 7 Mike A. Harris 2006-02-01 23:37:33 UTC
I believe you need to specify the layout as cz, and the variant as querty
for this to work in X11R7.

Comment 8 Sergey V. Udaltsov 2006-02-01 23:49:24 UTC
Yes it is now cz(qwerty). But I will probably add the compatibility rule for
cz_qwerty. Just to reduce further bug reports.

Comment 9 Mike A. Harris 2006-02-02 03:57:07 UTC
Each person experiencing this problem, please try the following:

setxkbmap -rules xorg -layout cz(qwerty)

Report back any success or errors.


Comment 10 Milan Kerslager 2006-02-02 12:05:53 UTC
This does not work:

# setxkbmap -rules xorg -layout 'cz(qwerty)'
Error loading new keyboard description
# setxkbmap -rules xorg -layout cz -variant qwerty
Error loading new keyboard description
# setxkbmap -rules xorg -layout cz
# (only the last command above works)

Comment 11 Milan Kerslager 2006-02-05 19:38:16 UTC
Changing summary to match current problem.

Comment 12 Milan Kerslager 2006-02-19 22:52:11 UTC
I updated to the current devel tree (ie mostly FC5test3) but layout cz variant
qwerty still does not work.

Comment 13 Libor Vanek 2006-02-20 11:27:57 UTC
I can confirm that - I also run "yum update" last week, czech keyboard is
working BUT only in "basic" layout - not in the "bksl", "qwerty" or "qwerty_bksl".

Comment 14 Miloslav Trmač 2006-02-20 18:21:07 UTC
See xorg bug 5077.  The patch
( fixes the other cz layouts.

Comment 15 Mike A. Harris 2006-02-21 10:35:53 UTC
Proper URL for reference:

Comment 16 Milan Kerslager 2006-02-21 21:50:01 UTC
Confirming the patch is working. Please include as bugfix before FC5 gold release.

However, there is another problem with gnome-keyboard-properties (from package
control-center-2.13.92-2) because there is very few modifiers available (to
switch keymaps etc). See bug #178163 for more info.

Comment 17 Mike A. Harris 2006-02-22 01:46:52 UTC
Resolved in rawhide xorg-x11-xkbdata-1.0.1-3

Comment 18 Miloslav Trmač 2006-02-22 23:49:19 UTC
Not really: the patch is in CVS, but not applied in the spec file.

Comment 19 Milan Kerslager 2006-02-23 13:51:34 UTC
Confirming that xorg-x11-xkbdata-1.0.1-3 does not contain the patch...

Comment 20 Mike A. Harris 2006-02-24 11:06:54 UTC
Doh.  Fixed in xorg-x11-xkbdata-1.0.1-4

Note You need to log in before you can comment on or make changes to this bug.