Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 177342 - fix inclusion of modprobe.conf.dist
Summary: fix inclusion of modprobe.conf.dist
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: module-init-tools
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2006-01-09 21:29 UTC by Bill Nottingham
Modified: 2014-03-17 02:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-24 18:57:19 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2006-01-09 21:29:01 UTC
Right now, we patch the module tools to automatically include modprobe.conf.dist.

This needs to be reworked to fit in better with upstream, either using include
statements (including adding the necessary include with a %post program) or
using /etc/modprobe.d.

Also, modprobe.conf.dist probably could stand some pruning - there's decent
chunks of it that aren't relevant any more.

Comment 1 Harald Hoyer 2006-01-24 14:10:42 UTC
what do you mean? get rid of module-init-tools-allconf.patch ??

Comment 2 Bill Nottingham 2006-01-24 18:57:19 UTC
Hm, looking at it again...

The issue is that current upstream module-init-tools only supports either
a) /etc/modprobe.conf
b) /etc/modprobe.d

We patch it to read modprobe.conf, then modprobe.d. If we went with upstream, we
would in theory have to move modprobe.conf to modprobe.d. However, that means
the first app to write a modprobe.conf (crappy nVidia %post script, or
something) would cause all the default state to not get read.  So maybe that's
not the best solution.

Probably best to just keep changing this for our packages.


Note You need to log in before you can comment on or make changes to this bug.