Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1773 - Bugzilla generates huge web pages for some/many queries
Summary: Bugzilla generates huge web pages for some/many queries
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General
Version: 2.1rC
Hardware: All
OS: Linux
high
medium vote
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-25 07:41 UTC by Chris Siebenmann
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-25 15:14:03 UTC


Attachments (Terms of Use)

Description Chris Siebenmann 1999-03-25 07:41:58 UTC
Bugzilla generates 200K+ web pages with greatest of ease.
This kind of sucks when you're on a dialup connection.

 Specifics: the huge pages are the specific bug pages you
get at through a query. They're probably huge because of
two things:
	- they have hyperlinks to every other bug that
	  your query turned up
and	- every such hyperlink has a list of *all* the
	  bug numbers encoded in it, so that 'next bug'
	  and 'previous bug' will work.

 Personally, I'd much rather have to back up one level
to the overall list of bugs a query turned up than have
big 200K web pages that take ages to download and a not
insignificant amount of time to render in Netscape.

 Reproduction: query for all bugs changed in the past two
days. You'll get a list between 100 and 200, depending on
how active people have been, and then you'll get to the
resulting really big per-bug web pages.

Comment 1 Need Real Name 1999-03-25 15:14:59 UTC
ok, the navigation bug list is now a dropdown menu that reduced the
page size of the "last 2 days" query from ~350K down to a more sane
~45K.


Note You need to log in before you can comment on or make changes to this bug.