Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 177130 - PATH is not transmitted through startkde
Summary: PATH is not transmitted through startkde
Keywords:
Status: CLOSED DUPLICATE of bug 177258
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-01-06 15:55 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-13 22:40:46 UTC


Attachments (Terms of Use)

Description Sammy 2006-01-06 15:55:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8) Gecko/20060103 Fedora/1.5-4 Firefox/1.5

Description of problem:
I noticed that some applications that I start from the KDE desktop don't have
the full system PATH defined to them. For example, I have graphical editors
that have a window for executing shell commands. If you start the application
from the konsole it has the full PATH.

I put an echo $PATH into startkde and got this:

/usr/local/bin:/usr/bin:/bin:/usr/bin:/usr/games

Whereas my path (say in konsole, coming from bash) is:

/usr/kerberos/bin:/usr/sbin:/sbin:/usr/bin:/bin:.:/usr/local/bin:/etc:/usr/ifc/bin

If I put this PATH into startkde and export it everyhting works fine. Perhaps
we need to source something in startkde.
Thanks

Version-Release number of selected component (if applicable):
kdebase-3.5.0-1.1

How reproducible:
Always

Steps to Reproduce:
1. Start an application from the desktop that can execute shell commands (not konsole)
2. 
3.
  

Additional info:

Comment 1 Sammy 2006-01-09 17:08:49 UTC
This seems to be related to the new bash. startkde is not considered a login
shell and therefor initilization files are not sourced. The following change
fixes the problem:

#!/bin/sh ------> #!/bin/bash -l



Comment 2 Sammy 2006-01-10 15:24:18 UTC
Please see:

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=177258

Something has changed in the kde/kdm startup to cause this but I could
not find it.

Comment 3 Ray Strode [halfline] 2006-01-13 22:40:46 UTC

*** This bug has been marked as a duplicate of 177258 ***

Comment 4 Tim Waugh 2006-01-17 09:51:10 UTC
Please try with bash-3.1-5.


Note You need to log in before you can comment on or make changes to this bug.