Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 176668 - Installer reports error: kernel does not recognize modified partition.
Summary: Installer reports error: kernel does not recognize modified partition.
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-29 10:21 UTC by Ken Hughes
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-06 03:55:26 UTC


Attachments (Terms of Use)

Description Ken Hughes 2005-12-29 10:21:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Whether manually or automatic partition setting soon after install of OS begins error message appears and installation halts.  When I changed the ext3 to ext2 in the partition editior the installation went through without error messages or halting.  Error message receive:error: Error: Error informing the kernel about modifications to partition /dev/hdb2 - Device or resource busy.  This means Linux won't know about any changes you made to /dev/hdb2 until you reboot - so you shouldn't mount it or use it in any way before rebooting.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Load Disc 1 fc4 iso.
2.modify partition using ext3.
3.Within initial install error message appears and halt.
  

Actual Results:  Only option was to reboot and start OS installation again.

Expected Results:  Successful loading of OS using ext3 format in partitions.

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 244, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
    diskset.savePartitions ()
  File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
    disk.commit()
error: Error: Error informing the kernel about modifications to partition /dev/hdb2 - Device or resource busy.  This means Linux won't know about any changes you made to /dev/hdb2 until you reboot - so you shouldn't mount it or use it in any way before rebooting.

Local variables in innermost frame:
self: <partedUtils.DiskSet instance at 0xb7d0ca2c>
disk: <PedDisk object at 0xb7f38308>


Package Group selection status:
ISO8859-9 Support: 0
Office/Productivity: 1
Compatibility Arch Development Support: 0
Engineering and Scientific: 0
MySQL Database: 0
Development Libraries: 0
Malay Support: 0
Portuguese Support: 0
Editors: 1
System Tools: 0
Japanese Support: 0
Hungarian Support: 0
Punjabi Support: 0
British Support: 0
Korean Support: 0
GNOME Software Development: 0
German Support: 0
Gaelic Support: 0
Faeroese Support: 0
Swedish Support: 0
Server: 0
Russian Support: 0
Text-based Internet: 1
Serbian Support: 0
KDE: 0
Gujarati Support: 0
Catalan Support: 0
Lithuanian Support: 0
X Software Development: 0
Workstation Common: 0
Legacy Network Server: 0
x86 Compatibility Arch Support: 0
GNOME Desktop Environment: 1
Dialup Networking Support: 1
Turkish Support: 0
Arabic Support: 0
Basque Support: 0
Everything: 0
Core: 0
Authoring and Publishing: 0
Irish Support: 0
Italian Support: 0
Slovak Support: 0
Base: 1
Slovenian Support: 0
FTP Server: 0
Java: 0
Network Servers: 0
Kannada Support: 0
GNOME: 0
Breton Support: 0
Romanian Support: 0
Games and Entertainment: 1
Greek Support: 0
Compatibility Arch Support: 0
Zulu Support: 0
Miscellaneous Included Packages: 0
Danish Support: 0
Afrikaans Support: 0
Legacy Software Development: 0
Brazilian Portuguese Support: 0
Cyrillic Support: 0
Welsh Support: 0
Thai Support: 0
Java Development: 0
Emacs: 0
Tamil Support: 0
Legacy Software Support: 0
Windows File Server: 0
X Window System: 1
Chinese Support: 0
Graphics: 1
Web Server: 0
Ruby: 0
Czech Support: 0
Bulgarian Support: 0
Indonesian Support: 0
Eclipse: 0
Galician Support: 0
Dutch Support: 0
Printing Support: 1
KDE Software Development: 0
Icelandic Support: 0
Ukrainian Support: 0
Assamese Support: 0
KDE (K Desktop Environment): 0
Bengali Support: 0
Mail Server: 0
Spanish Support: 0
Hebrew Support: 0
Estonian Support: 0
French Support: 0
Server Configuration Tools: 0
Croatian Support: 0
Language Support: 0
PostgreSQL Database: 0
Finnish Support: 0
Norwegian Support: 0
Administration Tools: 1
Polish Support: 0
News Server: 0
Hindi Support: 0
DNS Name Server: 0
Development Tools: 0
Sound and Video: 1
Graphical Internet: 1
ISO8859-2 Support: 0


PC Dell i386
2 IDE hard drives hda-Maxtor - 16G, hdb-Western Bell- 20G
primary, slave respective
Windows 2000 on primary, slave formatted in ntfs, initially
Memory 384MB
Processor PentiumIV 485Mhz
1 dvd-rom drive, 1 cd burner, 1 iomega disk drive, 1 floppy drive
1 ethernet card, 1 modem
N-vidia graphics card
Turtle Beach sound card

Comment 1 Jeremy Katz 2006-01-06 03:55:26 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.