Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 176435 - libvnc.so gone in vnc-server-4.1.1-31, broken in vnc-server-4.1.1-30.1
Summary: libvnc.so gone in vnc-server-4.1.1-31, broken in vnc-server-4.1.1-30.1
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-22 19:01 UTC by Alexandre Oliva
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 4.1.1-33
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-03 17:43:51 UTC


Attachments (Terms of Use)

Description Alexandre Oliva 2005-12-22 19:01:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051216 Fedora/1.5-3 Firefox/1.5

Description of problem:
When I upgraded xorg-x11-server-Xorg-1.0.0-1 yesterday, X would no longer start because of some __GL* symbol somewhere.  I downgraded to 0.93-1 and things got back to work.

Today I upgraded to 1.0.0-2, and it worked again, but it wasn't listening on the VNC port.  As it turned out, vnc-server-4.1.1-31 dropped libvnc.so entirely.  I hope this was just an oversight or some temporary change.

Anyhow, reverting to vnc-server-4.1.1-30.1, the problem of X no longer starting because of the __GL symbol came back.  I had to go back to the old xorg-x11-server-Xorg again in order to get the vnc service back.

Version-Release number of selected component (if applicable):
vnc-server-4.1.1-31 xorg-x11-server-Xorg-1.0.0-2

How reproducible:
Always

Steps to Reproduce:
1.Have `Load "vnc"' as a module in xorg.conf
2.Start X

Actual Results:  With the latest rawhide, X starts fine, but it fails to load the vnc module because it's not there (tried both i386 and x86_64).  With earlier vnc-server, X crashes.  With earlier vnc-server and X server, it works.

Expected Results:  libvnc.so should be brought back, ideally in a functional state :-)

Additional info:

Comment 1 Tim Waugh 2005-12-23 08:14:06 UTC
Caused by shipped libtool not setting shrext for some reason.

Comment 2 Tim Waugh 2005-12-23 12:00:56 UTC
Should be fixed in 4.1.1-32.  Thanks for the report.

Comment 3 Alexandre Oliva 2005-12-28 18:10:32 UTC
It is fixed as in the .so file is back in place, but it's still broken, in that
I have to revert to xorg-x11-server-Xorg-0.99.3-9 to get the latest vnc-server
to work as an X loadable module.  With xorg-x11-server-Xorg-1.0.0-3, Xorg.0.log
ends like this:

(II) Initializing built-in extension XEVIE
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295
No matching visual for __GLcontextMode with visual class = 1 (32774), nplanes =
4294967295


Comment 4 Tim Waugh 2006-01-03 13:24:37 UTC
That looks like an XEVIE problem.  However, I get this with the VNC extension:

 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on port 5901
X: symbol lookup error: /usr/lib/xorg/modules/extensions/libvnc.so: undefined
symbol: XCreateRegion


Comment 5 Tim Waugh 2006-01-03 17:43:51 UTC
Fixed in 4.1.1-33.

Comment 6 Alexandre Oliva 2006-01-05 16:55:54 UTC
Confirmed fixed, thanks!


Note You need to log in before you can comment on or make changes to this bug.