Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 176385 - RFE: Create udev rules for known printers.
Summary: RFE: Create udev rules for known printers.
Keywords:
Status: CLOSED DUPLICATE of bug 81164
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-22 00:43 UTC by David Woodhouse
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-26 09:43:26 UTC


Attachments (Terms of Use)

Description David Woodhouse 2005-12-22 00:43:21 UTC
When using multiple USB printers, the numbering of them can be fairly random.
It's much more useful to have a udev rule to create a symlink. For example, I've
created a file in /etc/udev/rules.d/ which contains this:

BUS=="usb", SYSFS{serial}=="00CNC2473891", SYMLINK="usb/lp_laserjet"
BUS=="usb", SYSFS{serial}=="ABCDE0311051619530", SYMLINK="usb/lp_epson"

... and then configured cups to use the symlinks instead of the numbered
/dev/usb/lp[01] devices. 

It would be useful if system-config-printer could set up stable symlinks for
itself this way.

Comment 1 David Woodhouse 2005-12-22 01:53:41 UTC
I still get another laserjet queue automatically added when I connect the
device, and a warning about not recognising the Epson:
   No match for USB device:
     mfr "EPSON"
     model "Stylus Photo 830U"
     desc "EPSON Stylus Photo 830U"
     cmdset "ESCPL2,BDC,D4"

I responded to the warning about the Epson, and now it's created a print queue
for me with a device URL along the lines of
hal:///org/freedesktop/Hal/devices/usb_device_.... I configured that queue as I
desire it, and all seems to be well.

However, the same doesn't work for the laserjet. Well, it _does_, but the print
queue then disappears when the usblp.ko module is unloaded. And when the
usblp.ko module is loaded again all the configuration changes I made are lost --
a completely new print queue is created instead. The Epson queue is still fine
though.

What I've done now is load the module, then run system-config-printer and
configured the queues as I desire them. Then I unloaded usblp.ko and clicked
'Apply' to save my changes. 

Now, when I load the usblp.ko module I get a _second_ laserjet queue which is
unconfigured, but my real laserjet and epson queues are still OK. So hotplugging
is sort of working as long as I don't care about the cosmetics.

Is this what the normal user is expected to do? All I wanted was to set the
print queue name and to make sure it's shared.

Comment 2 David Woodhouse 2005-12-22 02:05:53 UTC
Oh, maybe more than the name and the sharing... I also need to set my Epson
Stylus Colour 830U to Ink Type 'Four Color Standard' if I want grey to actually
come out grey; otherwise it looks like http://david.woodhou.se/testpage.jpeg

That seems a little strange to me -- I'm sure it's a 5-colour cartridge (and
separate black).

Comment 3 Tim Waugh 2006-01-26 09:43:26 UTC
This is essentially the same as bug #81164.  CUPS can use serial numbers to
distinguish USB printers from one another, and in fact left to its own devices
(heh) it will.

I need to make system-config-printer understand that.

*** This bug has been marked as a duplicate of 81164 ***


Note You need to log in before you can comment on or make changes to this bug.