Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 176311 - RPM command line parser is broken
Summary: RPM command line parser is broken
Keywords:
Status: CLOSED DUPLICATE of bug 151621
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-21 09:33 UTC by Thomas Roessler
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-21 09:40:30 UTC


Attachments (Terms of Use)

Description Thomas Roessler 2005-12-21 09:33:49 UTC
Description of problem:

rpm re-parses its command line and breaks when the path of an RPM includes space
characters.

Version-Release number of selected component (if applicable):
# rpm -q rpm   
rpm-4.4.1-22


How reproducible:
# rpm -i My\ Downloads/skype-1.2.0.18-fc3.i586.rpm 
error: open of My failed: No such file or directory
error: open of Downloads/skype-1.2.0.18-fc3.i586.rpm failed: No such file or
directory


Expected results:
Install the right RPM

Additional info:

Comment 1 Ignacio Vazquez-Abrams 2005-12-21 09:40:30 UTC

*** This bug has been marked as a duplicate of 151621 ***


Note You need to log in before you can comment on or make changes to this bug.