Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 176290 - RHEL3: raw(8) manpage has old information about dd
Summary: RHEL3: raw(8) manpage has old information about dd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux
Version: 3.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
: 146685 (view as bug list)
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2005-12-20 21:54 UTC by Buck Huppmann
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version: RHBA-2006-0456
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 14:46:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0456 normal SHIPPED_LIVE util-linux and mount bug fix update 2006-07-19 18:48:00 UTC

Description Buck Huppmann 2005-12-20 21:54:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11) Gecko/20021120 Netscape/7.01

Description of problem:
also wrong in RHE 4 package

raw(8)'s BUGS section says:

       The Linux dd (1) command does not  currently  align  its  buffers  cor-
       rectly, and so cannot be used on raw devices.

coreutils-4.5.3/src/dd.c says:

         The page alignment is necessary on any linux system that supports
         either the SGI raw I/O patch or Steven Tweedies raw I/O patch.
         It is necessary when accessing raw (i.e. character special) disk
         devices on Unixware or other SVR4-derived system.  */

      real_buf = xmalloc (input_blocksize
                          + 2 * SWAB_ALIGN_OFFSET
                          + 2 * page_size - 1);

and dd Works for Me

Version-Release number of selected component (if applicable):
util-linux-2.11y-31.11

How reproducible:
Always

Steps to Reproduce:
1. man 8 raw
2.
3.
  

Additional info:

it certainly seems to work (before it runs off the end of the disk):

% sudo /bin/raw /dev/raw/raw1 /dev/sda
/dev/raw/raw1:  bound to major 8, minor 0
% sudo /bin/raw /dev/raw/raw2 /dev/sdb
/dev/raw/raw2:  bound to major 8, minor 16
% sudo dd if=/dev/raw/raw1 of=/dev/raw/raw2 bs=512k
dd: reading `/dev/raw/raw1': No such device or address
140014+1 records in
140014+1 records out
%  head -1 /proc/partitions; grep -w sda /proc/partitions
major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect wuse running use aveq
   8     0   71687372 sda 1400125 68297763 282492438 1896570 16901 24763 334640 533560 0 1249410 2430030

Comment 1 Karel Zak 2006-02-15 10:47:18 UTC
There's same report for RHEL4: #181549.

Comment 4 Bob Johnson 2006-04-11 15:55:27 UTC
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 3.8 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 3.8 release.

Comment 8 Red Hat Bugzilla 2006-07-20 14:46:11 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0456.html


Comment 9 Karel Zak 2006-08-10 12:02:12 UTC
*** Bug 146685 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.