Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 176142 - Please enable Serbian translation in system-config-bind
Summary: Please enable Serbian translation in system-config-bind
Alias: None
Product: Fedora
Classification: Fedora
Component: libX11
Version: 5
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
Reported: 2005-12-19 18:11 UTC by Igor Miletic
Modified: 2009-03-11 09:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-02-08 21:38:15 UTC

Attachments (Terms of Use)

Description Igor Miletic 2005-12-19 18:11:34 UTC
Please enable Serbian translation in system-config-bind.

The locale(s) for Serbian are

sr_CS.UTF-8 (default, cyrillic script, available in CVS)
sr_CS.UTF-8@Latn (po files not yet available in CVS, still awaiting to be added
to ACL)

More info on these locales can be found here if needed:

The keyboard for sr_CS is "srp" in XKB. The latin locale sr_CS@Latn uses

The timezone for Serbia and Montenegro is GMT+0100.

Comment 1 Jason Vas Dias 2005-12-20 00:42:51 UTC
I noticed the updated 'sr.po' file in system-config-bind-4.0.0/po/sr.po -
this is now shipped in system-config-bind-4.0.0-33_FC5 - is this what you mean 
by 'enable Serbian translation' ? The translation has always been enabled, but
until now probably has not been correct. Please try out the new version - thanks!

Comment 2 Igor Miletic 2005-12-20 01:31:32 UTC
that was what I ment.

Thank you.

Comment 3 Fedora Update System 2005-12-20 03:02:18 UTC
From User-Agent: XML-RPC

system-config-bind-4.0.0-33 has been pushed for FC3, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 4 Fedora Update System 2005-12-20 03:02:42 UTC
From User-Agent: XML-RPC

system-config-bind-4.0.0-33_FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 5 Miloš Komarčević 2006-01-06 02:02:16 UTC
I still can't see the translated sr messages in these updated packages.

Comment 6 Jason Vas Dias 2006-01-09 23:23:58 UTC
OK, I've had another look at this issue.

Running system_config_bind with :
  # LC_ALL=sr_CS LANG=sr_CS system-config-bind
The ONLY translations seen are those done by libglade for the glade generated
buttons - no other translations, done by libgdk, are seen, and these messages
appear :
  'Gdk-WARNING **: locale not supported by Xlib'
  'Gdk-WARNING **: cannot set locale modifiers'

It appears this may be an Xlib bug. The libX11 package's 
contains information for the sr_YU locale (which no longer exists in glibc!)
not the sr_CS locale, which is the only sr_* locale listed by 'locale -a'  .

So once libX11 contains locale information for sr_CS, not sr_YU, the Serbian
translations should appear.

Comment 8 Miloš Komarčević 2006-01-09 23:47:59 UTC
When I said that I can't see the translation, I guess I meant the problem might
be that there are still no /usr/share/locale/sr/LC_MESSAGES/ nor
/usr/share/system-config-bind/po/sr/LC_MESSAGES/ in
Almost like they're not being built and shipped at all...

XOrg upstream should be ok AFAIK since other people have been working on our new
sr_CS locale support when the country code changed two years ago, other
translations show up fine so far...

Comment 9 Jason Vas Dias 2006-01-10 18:34:24 UTC
OK, sorry for the confusion - sr_* was missing from LINGUAS in the po/Makefile -
it is now added with system-config-bind-4.0.0-36* in FC5, FC4, and FC3 .

But I still get the messages from libgdm about Xlib not knowing about the sr_CS*
   $ LANG=sr_CS LC_ALL=sr_CS system-config-bind

   (system-config-bind:6517): Gdk-WARNING **: locale not supported by Xlib

   (system-config-bind:6517): Gdk-WARNING **: cannot set locale modifiers

This comes from the XSupportsLocale Xlib function, which cannot find anything
about the sr_CS locale (it only has information for the sr_YU locale), so 
XSetLocaleModifiers cannot be invoked and no Input Method modifiers can be
set - I think this should still be rectified in Xlib, since the sr_YU locale
is defunct.

Comment 10 Miloš Komarčević 2006-01-11 21:28:29 UTC
After checking with local people in the know, it really looks like the sr_CS
issue was never brought up upstream in XFree86/XOrg, so thanks Jason for
spotting that.

The upstream bug report is here:

Comment 11 Mike A. Harris 2006-01-31 18:58:08 UTC
Thanks, we'll track the issue in the upstream bugzilla.

Note You need to log in before you can comment on or make changes to this bug.