Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 176123 - up2date --channel checks for updates on all subscribed channels
Summary: up2date --channel checks for updates on all subscribed channels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Beth Nackashi
URL:
Whiteboard:
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2005-12-19 16:57 UTC by Beth Nackashi
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: RHBA-2006-0465
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 15:15:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0465 normal SHIPPED_LIVE up2date bug fix update 2006-07-19 20:50:00 UTC

Description Beth Nackashi 2005-12-19 16:57:39 UTC
Description of problem:
up2date --channel with no specified package checks for updates on all subscribed
channels.  It should only check for updates on the specified channel.

Version-Release number of selected component (if applicable):
up2date-4.4.56-3

How reproducible:
always

Steps to Reproduce:
1.  Install the latest up2date package.
2.  Subscribe a system to a base and at least one child channel.
3.  Run 'up2date --channel <child channel> -l'
  
Actual results:
up2date will check for updates on all subscribed channels


Expected results:
up2date should only check for updates on the specified child channel

Additional info:
[root@rlx-3-04 tmp]# up2date -l --channel rhn-tools-rhel-3-as-i386

Fetching Obsoletes list for channel: rhel-i386-as-3...

Fetching Obsoletes list for channel: rhn-tools-rhel-3-as-i386...

Comment 2 Fanny Augustin 2006-04-11 00:28:15 UTC
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release

Comment 3 Fanny Augustin 2006-04-13 19:31:43 UTC
Moving bugs to the CanFix List

Comment 4 Bret McMillan 2006-04-27 18:40:42 UTC
Should be fixed in >= 4.4.69-1  See #178498 for testplan.

Comment 6 Fanny Augustin 2006-05-09 19:37:04 UTC
This Bug has been fixed in this release

Comment 7 Beth Nackashi 2006-05-12 20:33:29 UTC
--channel=foo will now limit the channel universe for any operations, including
-u, pkgname, --installall, --showall, --showavailable, and -l.

Test plan:
1)  install a system, register it to multiple child channels (extras, fastrack,
and rhn-tools work rather well)
2)  use combinations of --channel=channel_label to see if the output makes sense:

'up2date --channel=foo -l' should list the available updated packages within foo.

'up2date --channel=foo --channel=bar --installall' should install anything
within the specified channels

Negative tests include:
 'up2date --channel=channel_i_dont_have_access_to -u'
 'up2date --channel=doesnt_exist --showall'


Manpage has been updated to eliminate the --installall tie.

Comment 8 Beth Nackashi 2006-05-12 21:10:43 UTC
Verified with up2date-4.4.69-8 and rhnlib-1.8.7-1 on i386, ia64, and x86_64.

Shown are example commands from i386 tests:

PASS-  up2date --channel=rhel-i386-as-3-extras -l
PASS-  up2date --channel=rhel-i386-as-3-extras --channel=rhn-tools-rhel-3-as-i386 -l
PASS-   up2date --channel=rhel-i386-as-3-extras
--channel=rhn-tools-rhel-3-as-i386 --installall (theoretically passed, but there
were some unresolved dependencies)

The negative tests resulted in a new bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=191555

I also looked at the manpage, and I'm not really sure what I was supposed to be
checking for there, since it looks pretty much like it did before.

Overall, up2date is now proven to only check the specified channel, which was
the point of this bug.


Comment 9 Beth Nackashi 2006-06-02 18:46:31 UTC
Reopening this bug per comments in 178498.

Comment 10 Bret McMillan 2006-06-06 15:55:09 UTC
Packages are built, should be fixed in up2date 4.4.69-14

Comment 11 Beth Nackashi 2006-06-08 18:50:07 UTC
--installall doesn't require a parameter.  Isn't it supposed to?



Comment 12 Bret McMillan 2006-06-14 15:19:46 UTC
It should require a parameter at this point.

Comment 13 Beth Nackashi 2006-06-20 17:14:13 UTC
[root@fjs-0-06 tmp]# up2date --installall=rhn-tools-rhel-3-as-i386
rhn-applet-actions -f
usage: up2date [OPTIONS] [<packages>]

/usr/sbin/up2date: error: --installall option does not take a value
[root@fjs-0-06 tmp]# rpm -q up2date
up2date-4.4.69-14


Comment 14 Bret McMillan 2006-06-20 19:10:03 UTC
-14 had some bad weirdness.  Repaired packages are -16.

Comment 17 Beth Nackashi 2006-06-20 19:42:36 UTC
These commands now work as they should.  This could mean they complete or fail,
depending.

up2date --channel=rhn-tools-rhel-3-as-i386 --channel=rhel-i386-as-3 rhn-applet
rhn-applet-actions -f

up2date --installall rhn-tools-rhel-3-as-i386 rhn-applet-actions -f

up2date --channel rhn-tools-rhel-3-as-i386 rhn-applet 


Comment 19 Red Hat Bugzilla 2006-07-20 15:15:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0465.html



Note You need to log in before you can comment on or make changes to this bug.