Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 176074 - [FC Devel] Anaconda mkswap labels confusing
Summary: [FC Devel] Anaconda mkswap labels confusing
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-19 01:41 UTC by Brian Long
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-01 18:45:15 UTC


Attachments (Terms of Use)
Change SWAP-device to SWPdevice for labels (deleted)
2005-12-19 01:44 UTC, Brian Long
no flags Details | Diff

Description Brian Long 2005-12-19 01:41:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Duplicate of bug 170500 for FC development.

If i install Fedora or RHEL on an HP Proliant server with CCISS hardware RAID and I specify two swap partitions, the labels Anaconda places on the swap partitions are  confusing:
LABEL=SWAP-cciss/c0d0p  swap                    swap    defaults        0 0
LABEL=SWAP-cciss/c0d01  swap                    swap    defaults        0 0

Anaconda appears to take the swap device (i.e. /dev/cciss/c0d0p3), prepend swap and cut off a few digits of the device to fit it into a 16-character space (I have read bug 127892).  If I run fdisk -l, I see two swap partitions:

Disk /dev/cciss/c0d0: 36.4 GB, 36413314560 bytes
255 heads, 63 sectors/track, 4427 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

           Device Boot      Start         End      Blocks   Id  System
/dev/cciss/c0d0p1   *           1          13      104391   83  Linux
/dev/cciss/c0d0p2              14        1057     8385930   83  Linux
/dev/cciss/c0d0p3            1058        1318     2096482+  82  Linux swap
/dev/cciss/c0d0p4            1319        4427    24973042+   5  Extended
/dev/cciss/c0d0p5            1319        1840     4192933+  82  Linux swap
/dev/cciss/c0d0p6            1841        2101     2096451   83  Linux
/dev/cciss/c0d0p7            2102        2362     2096451   83  Linux

I have no way to know if label SWAP-cciss/c0d0p is really c0d0p3 or p5.  To my knowledge, there is no equivalent to e2label I can run on an existing partition and extract the swap label.  mkswap -L is used to create the label only.

I would like to request that the label be condensed as much as possible such that the full c0d0p3 or c0d0p5 fits.  For example, SWAP could be reduced to SWP.  The - could be removed as well, making for LABEL=SWPcciss/c0d0p3 with one character to spare.

Version-Release number of selected component (if applicable):
anaconda CVS

How reproducible:
Always

Steps to Reproduce:
1. Kickstart hardware with cciss driver
2. Specify 2 or more swap partitions
3.
  

Actual Results:  fstab contains labels that do not point straight to a specific partition.

Expected Results:  fstab should contain swap labels with the full device name when possible.

Additional info:

This is a one-line patch to fsset.py and I would appreciate your consideration in this matter.

Comment 1 Brian Long 2005-12-19 01:44:52 UTC
Created attachment 122390 [details]
Change SWAP-device to SWPdevice for labels

This patch allows labels to appear as follows in /etc/fstab:
LABEL=SWPcciss/c0d0p3	swap			swap	defaults	0 0
LABEL=SWPcciss/c0d0p7	swap			swap	defaults	0 0

Since I can now see the partition information (instead of c0d01), I know which
fstab entry is which partition.

Comment 2 David Cantrell 2006-02-01 18:45:15 UTC
Patched fsset.py to use "SW-%s" for cciss partitions, but keep the "SWAP-%s"
naming method for non-cciss partitions.


Note You need to log in before you can comment on or make changes to this bug.