Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 175970 - Missing db2html-bibliography.xsl: yelp can't render any docbook help
Summary: Missing db2html-bibliography.xsl: yelp can't render any docbook help
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-doc-utils
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
: 176187 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-16 19:42 UTC by Dave Malcolm
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-22 15:12:45 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2005-12-16 19:42:37 UTC
Description of problem:
Yelp fails to generate HTML from a DocBook file; get an error dialog:

Could not process document

The document â/usr/share/gnome/help/user-guide/C/user-guide.xmlâ could not be
processed. The file â/usr/share/yelp/xslt/db2html.xslâ is either missing, or it
is not a valid XSLT stylesheet.

On starting from a terminal we get some extra debug output:
I/O warning : failed to load external entity "/usr/share/xml/gnome/xslt/d
ocbook/html/db2html-bibliography.xsl"
compilation error: file /usr/share/xml/gnome/xslt/docbook/html/db2html.xsl line
45 element include
xsl:include : unable to load
/usr/share/xml/gnome/xslt/docbook/html/db2html-bibliography.xsl

This was with gnome-doc-utils-0.5.1-1; db2html-bibliography.xsl is indeed
referenced but not installed (the various other stylesheets are) 

Looks like this was fixed 2 weeks ago in CVS in the upstream Makefile.am and we
need a new upstream tarball of gnome-doc-utils
http://cvs.gnome.org/viewcvs/gnome-doc-utils/xslt/docbook/html/Makefile.am?rev=1.23&view=log

Version-Release number of selected component (if applicable):
gnome-doc-utils-0.5.1-1.1

Comment 1 Dave Malcolm 2005-12-19 21:37:23 UTC
*** Bug 176187 has been marked as a duplicate of this bug. ***

Comment 2 Dave Malcolm 2005-12-22 15:12:45 UTC
Fixed in gnome-doc-utils-0.5.2-1



Note You need to log in before you can comment on or make changes to this bug.