Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 175880 - Yelp fails to open any docbook files, with error "An unknown error occured There is no default action associated with this location."
Summary: Yelp fails to open any docbook files, with error "An unknown error occured T...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yelp
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-15 22:08 UTC by Dave Malcolm
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-20 04:51:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 324926 None None None Never

Description Dave Malcolm 2005-12-15 22:08:30 UTC
Description of problem:
Yelp seems to be totally broken; any attempt to open an xml help file fails

Version-Release number of selected component (if applicable):
yelp-2.13.2-1
mozilla-1.7.12-2


How reproducible:
100%

Steps to Reproduce:
1.  Click on Desktop/System menu -> Help, or run "yelp" from terminal
2.  See "Help Topics", click on e.g. Desktop
3.  Mouseover "User Guide", then click it.
  
Actual results:
mouseover shows a local URL of an xml file, of the form
"file:/usr/share/blah/blah/blah.xml"
Clicking on it brings up an error dialog:
bold text "An unknown error occured"
extra text: "There is no default action associated with this location."


Expected results:
It should open the help file.

Comment 1 Dave Malcolm 2005-12-15 22:10:38 UTC
Confirmed on another machine, with yelp-2.13.1-1

Comment 2 Dave Malcolm 2005-12-15 23:51:48 UTC
It's doing a gnome_url_show on the URL, which internally calls
gnome_vfs_url_show_with_env, which appears to be returning
GNOME_VFS_ERROR_NO_DEFAULT


Comment 3 Dave Malcolm 2005-12-15 23:59:24 UTC
Looking in Nautilus at a typical file:
/usr/share/gnome/help/user-guide/C/user-guide.xml

It's reported as having mimetype:
application/docbook+xml

Open With tab gives no applications selected for handling files of type DocBook
document.




Comment 4 Dave Malcolm 2005-12-16 00:11:47 UTC
Looks like Yelp should be registered as a handler for DocBook files.

yelp.desktop.in.in (from upstream tarball) doesn't include any mime types, and
neither does the generated yelp.desktop (in the resulting rpm) 

See http://www.fedoraproject.org/wiki/ScriptletSnippets
for related packaging notes for the specfile.

Comment 5 Dave Malcolm 2005-12-16 16:46:02 UTC
That doesn't fix it, and running 
yelp /usr/share/gnome/help/user-guide/C/user-guide.xml
also fails (yelp tries to spawn an external progam, and if it's registered to
handle docbook, spawns itself in a loop)

Looks like get_doc_type doesn't recognize the new mimetype for DocBook, and is
returning YELP_DOC_TYPE_EXTERNAL; I'll patch this for our packages and send it
upstream...


Comment 6 Dave Malcolm 2005-12-16 17:08:56 UTC
Hmmm.. nautilus is reporting it as "application/docbook+xml", but inside yelp,
gnome_vfs_get_mime_type is reporting it as "application/xml".  (slow vs fast
mime sniffing?)  I'll patch it so that yelp can survive either...

Comment 7 Dave Malcolm 2005-12-16 17:24:45 UTC
Grrr... at least it can start loading the user guide now, but gives an error
dialog generating the HTML:

Could not process document

The document â/usr/share/gnome/help/user-guide/C/user-guide.xmlâ could not be
processed. The file â/usr/share/yelp/xslt/db2html.xslâ is either missing, or it
is not a valid XSLT stylesheet.

On starting from a terminal we get some extra debug output:
I/O warning : failed to load external entity "/usr/share/xml/gnome/xslt/d
ocbook/html/db2html-bibliography.xsl"
compilation error: file /usr/share/xml/gnome/xslt/docbook/html/db2html.xsl line
45 element include
xsl:include : unable to load
/usr/share/xml/gnome/xslt/docbook/html/db2html-bibliography.xsl


Comment 8 Dave Malcolm 2005-12-16 17:26:24 UTC
Seems to affect all documentation, not just the user guide...

Comment 9 Dave Malcolm 2005-12-16 19:28:59 UTC
This was with gnome-doc-utils-0.5.1-1; db2html-bibliography.xsl is indeed
referenced but not installed (the various other stylesheets are) 



Comment 10 Dave Malcolm 2005-12-16 19:34:13 UTC
Looks like this was fixed 2 weeks ago in the upstream Makefile.am and we need a
new upstream tarball of gnome-doc-utils:
http://cvs.gnome.org/viewcvs/gnome-doc-utils/xslt/docbook/html/Makefile.am?rev=1.23&view=log


Comment 11 Dave Malcolm 2005-12-16 19:48:37 UTC
I've filed the gnome-doc-utils problem here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=175970

Building with the fix for the mimetype problem into rawhide as yelp-2.13.2-2 

Comment 12 Dave Malcolm 2005-12-16 20:15:47 UTC
Sent upstream (with patch) here: http://bugzilla.gnome.org/show_bug.cgi?id=324296


Note You need to log in before you can comment on or make changes to this bug.