Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 175592 - .sp's get placed throughout man file text
Summary: .sp's get placed throughout man file text
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-13 03:29 UTC by Paul Dickson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.69.1-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-19 12:05:05 UTC


Attachments (Terms of Use)

Description Paul Dickson 2005-12-13 03:29:03 UTC
Description of problem:
xmlto is creating man files with the .sp groff commands not preceeded with a
space or linefeed.  Groff then doesn't see these and incorporates them into the
output text.

Version-Release number of selected component (if applicable):
xmlto-0.0.18-9

How reproducible:
Always

Steps to Reproduce:
1. yum install git-core-0.99.9a
2. man git-repack (although any of the man file will have this)
3.
  
Actual results:
Excerpt:

DESCRIPTION
       This script is used to combine all objects that do not currently reside
       in a "pack", into a pack..sp A pack is a collection of objects,
       individually compressed, with delta compression applied, stored in a
       single file, with an associated index file..sp Packs are used to reduce
       the load on mirror systems, backup engines, disk storage, etc..sp


Expected results:

DESCRIPTION
       This script is used to combine all objects that do not currently reside
       in a "pack", into a pack.

       A pack is a collection of objects, individually compressed, with delta
       compression applied, stored in a single file, with an associated index
       file.

       Packs are used to reduce the load on mirror systems, backup engines,
       disk storage, etc.


Additional info:
This may be due to xmlto's use of:
  http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
or xmlto's interpretation.

I downloaded
http://kernel.org/pub/software/scm/git/RPMS/SRPMS/git-0.99.9m-1.src.rpm and did
a "rpmbuild --rebuild" to verify the problem.

Comment 1 Tim Waugh 2005-12-13 10:02:25 UTC
Definitely a style-sheet issue; xmlto is a tiny shell script that just runs
xsltproc.

Comment 2 Tim Waugh 2005-12-13 10:03:00 UTC
Would be good to get this fixed for FC5.

Comment 3 Tim Waugh 2006-01-19 12:05:05 UTC
Fixed in docbook-style-xsl-1.69.1-3.


Note You need to log in before you can comment on or make changes to this bug.