Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 175550 - cvt_cyrusdb_all misidentifies skiplist files
Summary: cvt_cyrusdb_all misidentifies skiplist files
Keywords:
Status: CLOSED DUPLICATE of bug 163527
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-imapd
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Rockai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-12 18:16 UTC by Neal Groothuis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-12 11:14:31 UTC


Attachments (Terms of Use)

Description Neal Groothuis 2005-12-12 18:16:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Cyrus-imapd failed to start on our systems, reporting failure when "preparing databases".  I discovered that the problem was that /usr/lib/cyrus-imapd/cvt_cyrusdb_all misidentified skiplist files.  

Version-Release number of selected component (if applicable):
cyrus-imapd-2.2.12-1.1.fc3

How reproducible:
Always

Steps to Reproduce:
1.  Ensure that your system magic file contains the line:

4       string          skip            Apple QuickTime movie (modified)

2. Try to start cyrus-imapd using the init.d script (altnernatively, try to run /usr/lib/cyrus-imapd/cvt_cyrusdb_all).    

Actual Results:  cvt_cyrusdb_all fails, causing the startup script to fail.

Expected Results:  It should have realized that the "seen" files were skiplist files and moved on.

Additional info:

The fix is easy: change "$system_magic:$cyrus_magic" on line 144 to "$cyrus_magic:$system_magic" so that the cyrus magic file takes precedence and skiplist files are identified correctly.

Comment 1 Petr Rockai 2006-05-12 11:14:31 UTC

*** This bug has been marked as a duplicate of 163527 ***


Note You need to log in before you can comment on or make changes to this bug.