Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 175527 - kernel panic during boot
Summary: kernel panic during boot
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-12 11:59 UTC by Tim Waugh
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-17 18:40:24 UTC


Attachments (Terms of Use)
anaconda-ks.cfg (deleted)
2005-12-13 18:09 UTC, Tim Waugh
no flags Details
install.log (deleted)
2005-12-13 18:10 UTC, Tim Waugh
no flags Details

Description Tim Waugh 2005-12-12 11:59:00 UTC
Description of problem:
From a installation of today's rawhide I get a kernel panic during the boot
sequence.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1750_FC5 (i686)

How reproducible:
100%

Steps to Reproduce:
1. Boot.

Actual results:
...
EXT3-fs: mounted filesystem with ordered data mode.
Kernel panic - not syncing: Attempted to kill init!
panic+0x47/0x1c9         do_exit+0x35d/0x3ac
do_group_exit+0x29/0x8a  syscall_call+0x7/0xb

Additional info:
Booting with 'selinux=0' on the kernel command line seems to work around this
problem.

Comment 1 Dave Jones 2005-12-12 19:31:39 UTC
this has been there for a while, the policy rpm deletes a file in its %post that
it needs.  Probably a missing trigger.

Comment 2 Daniel Walsh 2005-12-13 04:42:03 UTC
No that is the old problem.  I believe these are from fresh install, and there
not being a policy file on reboot.  It should be fixed in todays rawhide.

Comment 3 Tim Waugh 2005-12-13 14:42:44 UTC
Hmm, there isn't even an selinux policy package installed!  This is from a
rawhide kickstart installation, so reassigning to anaconda.

-bash-3.00# rpm -qa |grep selinux
libselinux-python-1.29.1-2
libselinux-1.29.1-2


Comment 4 Tim Waugh 2005-12-13 14:44:03 UTC
Here are the relevant bits of the kickstart file:

install
nfs --server cyberelk --dir /mnt/archive/rh/i386
lang en_GB.UTF-8
keyboard us
xconfig --resolution 1600x1200 --depth 16 --defaultdesktop=GNOME
network --bootproto dhcp
rootpw --iscrypted ...
firewall --enabled --port=ipp:udp --port=ipp:tcp --port=ntp:udp --port=ssh:tcp
selinux --enforcing
authconfig --enableshadow --enablemd5
timezone --utc Europe/London
bootloader --location=mbr --append="rhgb quiet"

clearpart --all --initlabel --drives=hda
part /boot --fstype ext3 --size=50
part / --fstype ext3 --size=700 --grow
part swap --size=256 --grow --maxsize=512
reboot

%packages
@ office
@ x-software-development
@ gnome-desktop
@ dialup
@ editors
@ admin-tools
@ emacs
@ british-support
@ base-x
@ sound-and-video
@ printing
@ gnome-software-development
@ graphics
@ development-tools
@ games
@ text-internet
@ graphical-internet
e2fsprogs
kernel
vnc


Comment 5 Jeremy Katz 2005-12-13 15:41:18 UTC
Can you also attach /var/log/anaconda* and /root/install.log?   But I think this
should be fixed for real with the changes I made to the policy package yesterday

Comment 7 Tim Waugh 2005-12-13 18:10:36 UTC
Created attachment 122192 [details]
install.log

Comment 8 Tim Waugh 2005-12-19 17:33:30 UTC
I still get this, with yesterday's rawhide (20051218).

Comment 9 Jeremy Katz 2005-12-19 18:24:10 UTC
David -- can you look into why the default package selection doesn't seem to be
including the base and core groups?

Comment 10 Daniel Walsh 2006-01-02 17:13:44 UTC
Fixed in selinux-policy-2.1.6-19

Comment 11 Tim Waugh 2006-01-04 11:35:24 UTC
No, that RPM doesn't even get installed by anaconda -- and that's the problem.

Comment 13 David Cantrell 2006-01-04 19:08:03 UTC
At first glance, it looks like this is the problem in anaconda:

    def getDefaultGroups(self):
        log.warning("getDefaultGroups not implemented for backend!")
        pass

I'm looking further.

Comment 14 David Cantrell 2006-01-17 18:40:24 UTC
Chris fixed this in rawhide:

2006-01-11  Chris Lumens  <clumens@redhat.com>

        * kickstart.py (Kickstart.runTracebackScripts):  Typo fix.
        (Kickstart.setSteps):  Be smarter about skipping package selection.
        (Kickstart.setPackageSelection):  Add Core.


Comment 15 Tim Waugh 2006-01-18 12:07:45 UTC
Fix confirmed.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.