Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 175458 - black areas in VNC install
Summary: black areas in VNC install
Keywords:
Status: CLOSED DUPLICATE of bug 192289
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: David Lawrence
URL:
Whiteboard:
: 174383 (view as bug list)
Depends On:
Blocks: FC6Target FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2005-12-11 00:34 UTC by David Woodhouse
Modified: 2013-04-30 23:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-24 08:15:48 UTC


Attachments (Terms of Use)

Description David Woodhouse 2005-12-11 00:34:08 UTC
After my text install failed, I tried VNC.

There were some strange black areas during the package selection screen
(http://david.woodhou.se/vnc3.jpeg) and then after formatting the file systems
and starting the install, the VNC window just went black
(http://david.woodhou.se/vnc4.jpeg).

Comment 1 David Woodhouse 2005-12-11 00:35:07 UTC
The VNC server is now running.
Please connect to uranus.cambridge.redhat.com:1 to begin the install...
Starting graphical installation...
Press <enter> for a shell
Unable to read wel help text
Unable to read autopart help text
Unable to read netconf help text
Unable to read timezone help text
Unable to read accts help text
Unable to read aboutinstall help text
Unable to read installing help text

sh-3.00# ps axf
  PID TTY      STAT   TIME COMMAND
    1 ?        S      0:00 /init vnc
    2 ?        S      0:00 [migration/0]
    3 ?        SN     0:00 [ksoftirqd/0]
    4 ?        S      0:00 [watchdog/0]
    5 ?        S      0:00 [migration/1]
    6 ?        SN     0:00 [ksoftirqd/1]
    7 ?        S      0:00 [watchdog/1]
    8 ?        S      0:00 [migration/2]
    9 ?        SN     0:00 [ksoftirqd/2]
   10 ?        S      0:00 [watchdog/2]
   11 ?        S      0:00 [migration/3]
   12 ?        SN     0:00 [ksoftirqd/3]
   13 ?        S      0:00 [watchdog/3]
   14 ?        S      0:00 [migration/4]
   15 ?        SN     0:00 [ksoftirqd/4]
   16 ?        S      0:00 [watchdog/4]
   17 ?        S      0:00 [migration/5]
   18 ?        SN     0:00 [ksoftirqd/5]
   19 ?        S      0:00 [watchdog/5]
   20 ?        S      0:00 [migration/6]
   21 ?        SN     0:00 [ksoftirqd/6]
   22 ?        S      0:00 [watchdog/6]
   23 ?        S      0:00 [migration/7]
   24 ?        SN     0:00 [ksoftirqd/7]
   25 ?        S      0:00 [watchdog/7]
   26 ?        S<     0:00 [events/0]
   27 ?        S<     0:00 [events/1]
   28 ?        S<     0:00 [events/2]
   29 ?        S<     0:00 [events/3]
   30 ?        S<     0:00 [events/4]
   31 ?        S<     0:00 [events/5]
   32 ?        S<     0:00 [events/6]
   33 ?        S<     0:00 [events/7]
   34 ?        S<     0:00 [khelper]
   35 ?        S<     0:00 [kthread]
   42 ?        S<     0:00  \_ [kblockd/0]
   43 ?        S<     0:00  \_ [kblockd/1]
   44 ?        S<     0:00  \_ [kblockd/2]
   45 ?        S<     0:00  \_ [kblockd/3]
   46 ?        S<     0:00  \_ [kblockd/4]
   47 ?        S<     0:00  \_ [kblockd/5]
   48 ?        S<     0:00  \_ [kblockd/6]
   49 ?        S<     0:00  \_ [kblockd/7]
   53 ?        S<     0:00  \_ [khubd]
  112 ?        S      0:00  \_ [pdflush]
  113 ?        S      0:00  \_ [pdflush]
  115 ?        S<     0:00  \_ [aio/0]
  116 ?        S<     0:00  \_ [aio/1]
  117 ?        S<     0:00  \_ [aio/2]
  118 ?        S<     0:00  \_ [aio/3]
  119 ?        S<     0:00  \_ [aio/4]
  120 ?        S<     0:00  \_ [aio/5]
  121 ?        S<     0:00  \_ [aio/6]
  122 ?        S<     0:00  \_ [aio/7]
  193 ?        S<     0:00  \_ [khvcd]
  205 ?        S<     0:00  \_ [kseriod]
  618 ?        S<     0:00  \_ [scsi_eh_0]
  623 ?        S<     0:00  \_ [scsi_eh_1]
  637 ?        S<     0:00  \_ [rpciod/0]
  638 ?        S<     0:00  \_ [rpciod/1]
  639 ?        S<     0:00  \_ [rpciod/2]
  640 ?        S<     0:00  \_ [rpciod/3]
  641 ?        S<     0:00  \_ [rpciod/4]
  642 ?        S<     0:00  \_ [rpciod/5]
  643 ?        S<     0:00  \_ [rpciod/6]
  644 ?        S<     0:00  \_ [rpciod/7]
  820 ?        S<     0:00  \_ [xfslogd/0]
  821 ?        S<     0:00  \_ [xfslogd/1]
  822 ?        S<     0:00  \_ [xfslogd/2]
  823 ?        S<     0:00  \_ [xfslogd/3]
  824 ?        S<     0:00  \_ [xfslogd/4]
  825 ?        S<     0:00  \_ [xfslogd/5]
  826 ?        S<     0:00  \_ [xfslogd/6]
  827 ?        S<     0:00  \_ [xfslogd/7]
  828 ?        S<     0:00  \_ [xfsdatad/0]
  829 ?        S<     0:00  \_ [xfsdatad/1]
  830 ?        S<     0:00  \_ [xfsdatad/2]
  831 ?        S<     0:00  \_ [xfsdatad/3]
  832 ?        S<     0:00  \_ [xfsdatad/4]
  833 ?        S<     0:00  \_ [xfsdatad/5]
  834 ?        S<     0:00  \_ [xfsdatad/6]
  835 ?        S<     0:00  \_ [xfsdatad/7]
  836 ?        S<     0:00  \_ [xfsbufd]
  871 ?        S<     0:00  \_ [kmirrord]
 1044 ?        S<     0:00  \_ [kauditd]
   74 ?        S      0:00 [rtasd]
  114 ?        S      0:00 [kswapd0]
  427 ?        S      0:00 /init vnc
  428 ?        S      0:03 /sbin/loader --virtpconsole /dev/hvc0
  675 tty2     Ss+    0:00  \_ -/bin/sh
  885 ?        S      0:02  \_ /usr/bin/python /usr/bin/anaconda -m nfs://mnt/so
  904 ?        S      0:02      \_ //usr/bin/Xvnc :1 -nevershared -depth 16 -geo
  905 ?        S      0:00      \_ //usr/bin/mini-wm --display :1
  908 ?        Z      4:05      \_ [anaconda] <defunct>
 1050 ?        S      0:00      \_ /bin/sh
 1051 ?        R      0:00          \_ ps axf
  645 ?        S<     0:00 [loop0]
  788 ?        S      0:00 [jfsIO]
  789 ?        S      0:00 [jfsCommit]
  790 ?        S      0:00 [jfsCommit]
  791 ?        S      0:00 [jfsCommit]
  792 ?        S      0:00 [jfsCommit]
  793 ?        S      0:00 [jfsCommit]
  794 ?        S      0:00 [jfsCommit]
  795 ?        S      0:00 [jfsCommit]
  796 ?        S      0:00 [jfsCommit]
  797 ?        S      0:00 [jfsSync]
 1038 ?        S      0:00 [kjournald]
 1039 ?        S      0:00 [kjournald]
 1047 ?        S      0:00 /usr/bin/python /usr/bin/anaconda --syslogd /mnt/sysi

sh-3.00# cat /mnt/sysimage/root/install.log
Installing libgcc-4.1.0-0.6.ppc64.
Installing libgcc-4.1.0-0.6.ppc.
Installing setup-2.5.47-1.1.noarch.
warning: setup-2.5.47-1.1: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
Installing filesystem-2.3.7-1.ppc.
Installing fedora-logos-1.1.34-1.noarch.
Installing gnome-mime-data-2.4.2-1.ppc.
warning: gnome-mime-data-2.4.2-1: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Installing basesystem-8.0-5.noarch.
Installing mailcap-2.1.19-1.noarch.
Installing termcap-5.4-7.noarch.
Installing cracklib-dicts-2.8.6-1.ppc.
Installing xorg-x11-xkbdata-0.99.1-2.noarch.
Installing rmt-0.4b40-5.ppc.
Installing slib-3a1-5.noarch.
Installing desktop-backgrounds-basic-2.0-30.1.noarch.
Installing iso-codes-0.47-1.noarch.
Installing bsf-2.3.0-6jpp_2fc.noarch.
Installing tzdata-2005n-2.noarch.
Installing glibc-common-2.3.90-18.ppc.



Comment 2 David Woodhouse 2005-12-11 01:38:01 UTC
stracing the installer didn't enlighten me much. It deadlocks if I do that, when
installing the first package...

clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0xf7ffa048) = 1061
rt_sigprocmask(SIG_SETMASK, NULL, [CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
rt_sigprocmask(SIG_SETMASK, NULL, [], 8) = 0
rt_sigprocmask(SIG_SETMASK, [CHLD], NULL, 8) = 0
close(72)                               = 0
close(73)                               = 0
gettimeofday({1134264961, 31036}, NULL) = 0
rt_sigprocmask(SIG_SETMASK, NULL, [CHLD], 8) = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
--- SIGCHLD (Child exited) @ 0 (0) ---
waitpid(0, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], WNOHANG) = 1061
waitpid(0, 0xffef6b9c, WNOHANG)         = 0
rt_sigreturn(0)                         = 0
futex(0x12c78504, FUTEX_WAIT, 1, NULL


Comment 3 David Woodhouse 2005-12-11 01:56:24 UTC
Upon reproducing with 'debug' I see it get as far as installing glibc-common
again before it stops, although this time the screen isn't black and anaconda
still appears to be running. There's interesting stuff in
/mnt/sysimage/root/anaconda.log now though...

Installing libgcc-4.1.0-0.6.ppc64.
Installing libgcc-4.1.0-0.6.ppc.
Installing setup-2.5.47-1.1.noarch.
warning: setup-2.5.47-1.1: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
Installing filesystem-2.3.7-1.ppc.
Installing fedora-logos-1.1.34-1.noarch.
Installing gnome-mime-data-2.4.2-1.ppc.
warning: gnome-mime-data-2.4.2-1: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Installing basesystem-8.0-5.noarch.
Installing mailcap-2.1.19-1.noarch.
Installing termcap-5.4-7.noarch.
Installing cracklib-dicts-2.8.6-1.ppc.
Installing xorg-x11-xkbdata-0.99.1-2.noarch.
Installing rmt-0.4b40-5.ppc.
Installing slib-3a1-5.noarch.
Installing desktop-backgrounds-basic-2.0-30.1.noarch.
Installing iso-codes-0.47-1.noarch.
Installing bsf-2.3.0-6jpp_2fc.noarch.
Installing tzdata-2005n-2.noarch.
Installing glibc-common-2.3.90-18.ppc.
warning: user H does not exist - using root
warning: user \uffff\uffff does not exist - using root
warning: user an1/GET.1.gz does not exist - using root
warning: user gz does not exist - using root
warning: user init/Xclients.d does not exist - using root
warning: user .0 does not exist - using root
warning: user \uffff$T does not exist - using root
warning: user /suexec.8.gz does not exist - using root
warning: user ec.8.gz does not exist - using root
warning: user gz does not exist - using root
warning: user t/ does not exist - using root
warning: user \uffff\uffff\uffff does not exist - using root
warning: user r/share/man/man8/httpd.8.gz does not exist - using root
warning: user n/man8/httpd.8.gz does not exist - using root
...etc....

If I now attach with strace, I see it's just doing this...

futex(0x1285bf70, FUTEX_WAIT, 2, NULL)  = -1 EAGAIN (Resource temporarily
unavailable)
futex(0x1285bf70, FUTEX_WAIT, 2, NULL)  = -1 EAGAIN (Resource temporarily
unavailable)
futex(0x1285bf70, FUTEX_WAIT, 2, NULL)  = -1 EAGAIN (Resource temporarily
unavailable)

The package appears to be fine...
$ md5sum glibc-common-2.3.90-18.ppc.rpm ; rpm --checksig
glibc-common-2.3.90-18.ppc.rpm
00ef660bedf55603d9d396311add9fd1  glibc-common-2.3.90-18.ppc.rpm
glibc-common-2.3.90-18.ppc.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS:
GPG#30c9ecf8)



Comment 4 Jeremy Katz 2005-12-12 16:38:32 UTC
The black screen is all Xvnc -- there's really not much we do which can
influence that one way or another :)

Comment 5 David Woodhouse 2005-12-12 17:06:41 UTC
The file system panic is fixed by reverting the recent changes to the service
partition, and the install completed successfully (modulo selinux bugs qv)

Comment 6 Tim Waugh 2005-12-12 17:34:29 UTC
David: does the black-screen-from-vnc-install problem still happen after
reverting those changes?

Comment 7 David Woodhouse 2005-12-12 21:27:16 UTC
The final all-black screen (vnc4.jpeg), which I think happened because anaconda
had crashed or aborted, no longer happens. However, I do still see the partial
areas of black, such as in http://david.woodhou.se/vnc3.jpeg and
http://david.woodhou.se/vnc-part2.jpeg.

Note that the black region in vnc-part2.jpeg goes only black when the top-most
dialog box pops up; until then it was fine (cf. vnc-part1.jpeg).

Comment 8 Tim Waugh 2005-12-13 09:59:18 UTC
From the look of the screenshot you are using a limited colour palette; perhaps
enabling full colour (F8->Options) will give better results?

Anyway, it seems as though VNC isn't really the issue here.

Comment 9 Tim Waugh 2005-12-13 09:59:48 UTC
Reassigning.

Comment 10 David Woodhouse 2005-12-13 14:41:59 UTC
Full colour doesn't help -- it makes the non-black bits slightly prettier, but
the black parts remain black.

Comment 11 Jeremy Katz 2006-01-31 20:45:03 UTC
Is this still occurring?  I haven't seen it at all (and have done a lot of vnc
installs for Xen)

Comment 12 David Woodhouse 2006-02-01 00:12:54 UTC
I had a report the other day that it was still happening -- will test when I get
home next week.

Comment 13 Paul Nasrat 2006-02-02 02:00:22 UTC
Black backing for vnc on ppc seen again today on a install on a ppc box with VNC
- if you need access to a ppc box to test please let me know, and one can be
arranged.  

Comment 14 Adrian Reber 2006-02-20 14:53:31 UTC
I can confirm this with 4.92:

http://lisas.de/~adrian/vnc1.png
http://lisas.de/~adrian/vnc2.png

Comment 15 David Woodhouse 2006-03-29 16:19:19 UTC
And with the final release of FC5.

Comment 16 Paul Nasrat 2006-07-05 14:28:13 UTC
*** Bug 197677 has been marked as a duplicate of this bug. ***

Comment 17 Paul Nasrat 2006-07-05 14:29:39 UTC
We really need to fix this - Jitka Kudrnacova please let me know if you need
access to a system to debug.

Comment 18 IBM Bug Proxy 2006-07-05 14:42:49 UTC
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|RH197677- fields in certain |RH175458- fields in certain
                   |installation dialog windows |installation dialog windows
                   |appear black                |appear black




------- Additional Comments From chavez@us.ibm.com(prefers email via lnx1138@us.ibm.com)  2006-07-05 10:48 EDT -------
Cross-referencing over to RH BZ 175458 which looks to be a FC5 bug. I expect the
same fix will end up in RHEL 5? 

So for my own benefit, had we opened both an FC5 and RHEL 5 bug reporting the
same bug (without there being either already opened to dup to) would one have
been dup'd to the other? 

Comment 19 Jitka Kozana 2006-07-17 08:31:24 UTC
I have found out, that these black areas occur in all gtk applications, not 
only in anaconda. 
Non-gtk applications are not affected. 

Comment 20 David Woodhouse 2006-09-27 15:02:18 UTC
Why is this only FC6Target and not FC6Blocker?

Comment 21 David Woodhouse 2006-10-04 14:41:50 UTC
Still in FC6 even now. This was reported before FC5. When is it going to get fixed?



Comment 22 Adam Tkac 2006-10-11 16:04:29 UTC
*** Bug 174383 has been marked as a duplicate of this bug. ***

Comment 23 Adam Tkac 2006-10-24 08:15:48 UTC

*** This bug has been marked as a duplicate of 192289 ***


Note You need to log in before you can comment on or make changes to this bug.