Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 175202 - Xv does not detect any overlays with the savage driver
Summary: Xv does not detect any overlays with the savage driver
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-savage
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-07 17:57 UTC by sketch
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-03 12:25:20 UTC


Attachments (Terms of Use)

Description sketch 2005-12-07 17:57:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
Hardware: 5333:82ce S3 SuperSavage IX/C SDR (rev 05)

Xv does not detect any overlays.  The extension is loaded according to Xorg.0.log, but xvinfo says no screens available.  Unfortunately, there is no other output in the log about Xv, whether it works or not.  Xv worked fine in the old version of X with FC4.  In fact, removing the modularized X RPM's and installing the xorg-x11-* RPM's from FC4 updates on top of FC5test1 results in Xv working fine, so I think that kernel DRM or other changes can be ruled out.


Version-Release number of selected component (if applicable):
xorg-x11-drv-savage-2.0.2-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC5test1
2. Open Terminal
3. run "xvinfo"


Actual Results:  X-Video Extension version 2.2
screen #0
  no screens found


Expected Results:  X-Video Extension version 2.2
screen #0
  Adapter #0; "Savage Streams Engine"
...

Additional info:

Comment 1 Mike A. Harris 2005-12-09 20:12:52 UTC
Thanks for the report.  I've investigated this a bit, and it seems that the
X.Org upstream savage driver currently does not have Xv enabled due to a
bug in the monolithic->modular X.Org migration.  Upstream is aware of the
problem, which seems to affect other drivers as well.  A future build of
the driver should have Xv re-enabled again.

I'll update the report once we have updated the driver for this problem.

Thanks again.



Comment 2 Mike A. Harris 2006-02-03 12:25:20 UTC
An updated savage driver is available, which may resolve this problem now.

xorg-x11-drv-savage-2.0.2.3-1 or newer is required

Please update all packages on your system to the latest Fedora development
updates.  If the problem persists however, then it is recommended to file
a bug report to X.org bugzilla at http://bugs.freedesktop.org in the "xorg"
component, and it will probably be fixed in the next upstream savage driver
release, which we'll incorporate into Fedora.

Thanks for testing.


Note You need to log in before you can comment on or make changes to this bug.