Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 174715 - clean all in 2.4.1-1 reacting badly with the new cache feature
Summary: clean all in 2.4.1-1 reacting badly with the new cache feature
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
: 174864 174938 175076 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-01 17:19 UTC by Jef Spaleta
Modified: 2014-01-21 22:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-05 16:00:23 UTC


Attachments (Terms of Use)
Patch to clean cookies along with metadata (deleted)
2005-12-01 19:44 UTC, Panu Matilainen
no flags Details | Diff

Description Jef Spaleta 2005-12-01 17:19:24 UTC
Description of problem:
cachecookie files are not being cleaned as part of clean operations.
as a result the next run of yum can't find the repodata and no longer attempts
to contact a server to refresh.

Version-Release number of selected component (if applicable):
2.4.1-1

How reproducible:


Steps to Reproduce:
1. install 2.4.1-1
2. yum check-update  to see mirror contact and to create the cookie files
3. yum check-update  to see the new caching prevents contacting a mirror
4. yum clean all
5. yum check-update  instant death.  
6. remove all cachecookie files in the cache directory tree
7. yum check-update   works as expected



Additional info:

what is the default length of time till cookies expire?
how do i configure that length of time?
and how do i turn this feature off?

Comment 1 Seth Vidal 2005-12-01 18:49:04 UTC
hyperbole, much?
answers:
- the clean command should kill off this cookie, I agree - I'll look into it
- it's documented in the man page: metadata_expire=0 will disable the caching
- the current time is 8 hours and then it goes away. It can be set per-repo, of
course, so for the rapidly changing repos you can set it low and for the
uncommonly changing repos you can leave it alone.



Comment 2 Panu Matilainen 2005-12-01 19:44:56 UTC
Created attachment 121703 [details]
Patch to clean cookies along with metadata

Patch as suggested by Seth on yum-devel:
- clean the cookies on 'yum clean metadata' instead of separate operation
- force refresh of cookies on 'yum makecache'

Comment 3 Seth Vidal 2005-12-02 03:49:19 UTC
Panu, check it in. And Jeremy, if you want apply this as a patch to fedora's yum
package for 2.4.1 and give it another test run in updates-testing, okay?

Comment 4 Seth Vidal 2005-12-03 05:28:27 UTC
*** Bug 174864 has been marked as a duplicate of this bug. ***

Comment 5 Ignacio Vazquez-Abrams 2005-12-04 17:17:40 UTC
*** Bug 174938 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2005-12-05 16:00:23 UTC
Applied Panu's patch as well as the change to bump the default cache time to 30
minutes for FC4 updates and devel

Comment 7 Seth Vidal 2005-12-06 15:12:15 UTC
*** Bug 175076 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.