Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 174702 - Segmentation fault when starting Xvnc
Summary: Segmentation fault when starting Xvnc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-12-01 15:53 UTC by Brian Gerst
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 4.1.1-27
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-06 14:48:19 UTC


Attachments (Terms of Use)

Description Brian Gerst 2005-12-01 15:53:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
Program received signal SIGSEGV, Segmentation fault.
0x0000000000413f11 in vfbScreenInit (index=Variable "index" is not available.
) at xvnc.cc:874
874         for (vis = pScreen->visuals; vis->vid != pScreen->rootVisual; vis++)


Version-Release number of selected component (if applicable):
vnc-server-4.1.1-24

How reproducible:
Always

Steps to Reproduce:
1. Start Xvnc :1
2.
3. 

Actual Results:  Xvnc Free Edition 4.1.1
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 69999902, The X.Org Foundation


Program received signal SIGSEGV, Segmentation fault.
0x0000000000413f11 in vfbScreenInit (index=Variable "index" is not available.
) at xvnc.cc:874
874         for (vis = pScreen->visuals; vis->vid != pScreen->rootVisual; vis++)
Current language:  auto; currently c++
(gdb) bt
#0  0x0000000000413f11 in vfbScreenInit (index=Variable "index" is not available.
) at xvnc.cc:874
#1  0x00000000004317ec in AddScreen (pfnInit=0x413bde <vfbScreenInit>, argc=2, argv=0x7fffffcc6b28) at main.c:781
#2  0x0000000000414259 in InitOutput (screenInfo=0x670de0, argc=2, argv=0x7fffffcc6b28) at xvnc.cc:964
#3  0x0000000000432048 in main (argc=2, argv=0x7fffffcc6b28, envp=Variable "envp" is not available.
) at main.c:372
#4  0x00000039b5f1ce9f in __libc_start_main () from /lib64/libc.so.6
#5  0x0000000000413419 in _start ()
#6  0x00007fffffcc6b18 in ?? ()
#7  0x0000000000000000 in ?? ()


Expected Results:  It runs.

Additional info:

Comment 1 Tim Waugh 2005-12-01 16:12:04 UTC
Indeed.  Actually for 'how to reproduce' you need to connect an X client first.
 But this is now fixed.  Thanks for testing!

*** This bug has been marked as a duplicate of 173323 ***

Comment 2 Brian Gerst 2005-12-01 16:24:51 UTC
In my case, it never got far enough to allow client connections.  The segfault
was immediate on startup.

Comment 3 Brian Gerst 2005-12-02 16:21:08 UTC
Updated to vnc-server-4.1.1-26 and still getting the segfault.

Comment 4 Tim Waugh 2005-12-02 16:22:55 UTC
Different stack trace?

Comment 5 Brian Gerst 2005-12-02 16:25:21 UTC
Same backtrace.

Comment 6 Brian Gerst 2005-12-02 16:27:39 UTC
Just for kicks I installed the i386 version and it works, so the problem is
x86_64 specific.

Comment 7 Tim Waugh 2005-12-06 14:48:19 UTC
This should be fixed in 4.1.1-27.


Note You need to log in before you can comment on or make changes to this bug.