Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 174467 - user password required for system-wide WEP key
Summary: user password required for system-wide WEP key
Keywords:
Status: CLOSED DUPLICATE of bug 154652
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target 176728 F8Target
TreeView+ depends on / blocked
 
Reported: 2005-11-29 12:21 UTC by David Woodhouse
Modified: 2008-02-12 14:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-12 14:42:47 UTC


Attachments (Terms of Use)
login prompt for NM (deleted)
2005-12-30 12:31 UTC, jim
no flags Details

Description David Woodhouse 2005-11-29 12:21:06 UTC
The new version of NetworkManager makes me enter my password to the GNOME
keyring thingy before it will connect to the wireless network.

The WEP key is a system-wide thing; that's why it's stored in
/etc/sysconfig/network-scripts/key-eth1. NetworkManager ought to connect without
user interaction, as it used to in FC4.

Comment 1 jim 2005-12-30 12:31:24 UTC
Created attachment 122641 [details]
login prompt for NM

Comment 2 Chris Chabot 2006-01-04 18:59:35 UTC
I reported something like this before in bug #172555 
Hope to see it fixed some day :-)

Comment 3 David Woodhouse 2006-01-09 18:08:07 UTC

*** This bug has been marked as a duplicate of 172555 ***

Comment 4 Ray Strode [halfline] 2006-01-11 15:34:29 UTC
This is actually a really hard problem to solve.  We can't let every user of a
machine have access to one persons VPN, for instance.  This same idea can be
extended to access points (who's to say the access point is not connected to a
local intranet only type thing?).  This gets even more complicated when you
factor in things like fast user switching.  The bottom line is the problem is
not going to get solved for FC5.

Comment 5 David Woodhouse 2006-01-11 15:41:57 UTC
You already _do_ let every user of the machine access the VPN while it's up. You
haven't played with iptables and per-user filtering, have you? That's a bogus
argument.

It would be fairly simple to put keys somewhere which are usable by
NetworkManager  in the absence of any given user. Ideally you'd use the keys
which are always configured with system-config-network.

Comment 6 David Woodhouse 2007-03-25 19:51:04 UTC
This seems to have got worse. Now I'm asked for the password every time my
machine comes back from suspend-to-RAM.

Comment 7 Will Woods 2007-05-11 21:14:59 UTC
This works for me with current rawhide - I'm asked for my password once and only
once.

David, can you confirm and either close this bug or move it to F8Target (so we
can push for a proper solution next release)?

Comment 8 Matthias Clasen 2007-05-17 17:48:33 UTC
This is unlikely to see any action before f7 final.

Comment 9 David Woodhouse 2007-07-30 09:57:20 UTC
I'm still asked for a password. Just once, but even that is too much, and is a
regression since FC4.

Comment 10 W. Michael Petullo 2007-08-26 21:14:12 UTC
Have you guys tried pam_keyring?  The pam_keyring module unlocks gnome-keyring
with the system password a user provides to log in.

Comment 11 Dan Williams 2008-02-12 14:42:47 UTC

*** This bug has been marked as a duplicate of 154652 ***


Note You need to log in before you can comment on or make changes to this bug.