Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1742 - lilo can fail to install.
Summary: lilo can fail to install.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
: 1334 1451 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-24 17:01 UTC by Jeremiah Johnson
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-25 03:47:49 UTC


Attachments (Terms of Use)

Description Jeremiah Johnson 1999-03-24 17:01:01 UTC
If you "make" a msdos partition with diskdruid during
installation, lilo will fail to install. This is because the
device does not have a valid filesystem. I reported this to
dale before beta testing for 5.6.x+ when I found it while
installing RH 5.2, he said that if it appeared in the beta's
to let you know. So now I am.

Comment 1 Preston Brown 1999-03-26 21:33:59 UTC
this one looks nasty Matt.

Comment 2 Matt Wilson 1999-04-01 05:51:59 UTC
*** Bug 1334 has been marked as a duplicate of this bug. ***

Lilo warnings are not shown to the user if they occur during
installation.  As some lilo warnings indicate a serious
problem you can easily get caught out and lock up your
machine.

------- Additional Comments From gafton@redhat.com  03/18/99 19:40 -------
assigned to msw

Comment 3 Matt Wilson 1999-04-01 05:58:59 UTC
*** Bug 1451 has been marked as a duplicate of this bug. ***

At the end of the install for 5.2 the user is asked where
lilo should be installed.  I selected Master Boot Record.
The write of the loader to the Boot Record failed.  I tried
and tried to install lilo via the normal install.
Eventually I found that the installer had written a
lilo.conf file that was too big to be written to the
boot sector.  So I removed some entries and then ran lilo.
I would think that a safeguard would be in place to
keep lilo.conf from growing to be too big.

------- Additional Comments From msw@redhat.com  04/01/99 00:57 -------
it's not that the lilo entries were too big - it's probably that there
was an entry for "dos" in the lilo configuration pointing at a dos
filesystem that didn't have a valid boot block on it.

Comment 4 Bill Nottingham 1999-09-25 03:47:59 UTC
*** This bug has been marked as a duplicate of 4 ***


Note You need to log in before you can comment on or make changes to this bug.