Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 173936 - bash doesn't honor .bash_profile in gnome-terminal
Summary: bash doesn't honor .bash_profile in gnome-terminal
Keywords:
Status: CLOSED DUPLICATE of bug 177258
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-22 20:01 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-03 13:54:09 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2005-11-22 20:01:05 UTC
Description of problem:
bash doesn't honor ~/.bash_profile. I start a gnome-terminal, and the variables
and so set there aren't available.

Version-Release number of selected component (if applicable):
bash-3.0-36

How reproducible:
Always

Steps to Reproduce:
1. Start a gnome-terminal in gnome
2.
3.
  
Actual results:
Contents of .bash_profile aren't considered.

Expected results:
Read in .bash_profile

Additional info:
/var/log/secure shows the following after a failed login attepmt:
Nov 22 16:54:29 quelen sshd[27274]: PAM unable to
dlopen(/lib/security/$ISA/pam_ldap.so)
Nov 22 16:54:29 quelen sshd[27274]: PAM [dlerror: /usr/lib64/libldap-2.2.so.7:
undefined symbol: SSL_CTX_set_tmp_rsa_callback]
Nov 22 16:54:29 quelen sshd[27274]: PAM adding faulty module:
/lib/security/$ISA/pam_ldap.so

Comment 1 Horst H. von Brand 2005-11-23 20:21:43 UTC
Sorry, the additional info is for another bug (with LDAP).

Comment 2 Willem Riede 2005-12-28 22:14:42 UTC
I observed the same - you can detect it by looking at $PATH - ~/bin is not added.

Comment 3 Tim Waugh 2006-01-03 13:54:09 UTC
The .bash_profile file is sourced only for a login shell (see 'man bash').  One
way to invoke bash as a login shell is to use the '-l' option, so if you want
.bash_profile sourced from gnome-terminal you need to enable the 'Run command as
a login shell' check-button in the gnome-terminal "Edit profile" dialog box.

Comment 4 Willem Riede 2006-01-03 23:05:30 UTC
Given that this was not needed in FC4, can this be flagged in the release notes,
or perhaps better, can that check-button be set by default?

Comment 5 Ray Strode [halfline] 2006-01-10 16:03:42 UTC
Hi guys,

This is fixed in rawhide now.  It was a bug in GDM (the component that provides
the login screen).

When someone logs in, a login shell should be executed.  That wasn't happening.

*** This bug has been marked as a duplicate of 177258 ***


Note You need to log in before you can comment on or make changes to this bug.