Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 173789 - mime.types is missing the right associations to OpenOffice.org documents
Summary: mime.types is missing the right associations to OpenOffice.org documents
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mailcap
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Ben Levenson
URL:
Whiteboard:
: 201007 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-11-21 06:38 UTC by Reuben Farrelly
Modified: 2008-03-11 13:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-13 13:00:39 UTC


Attachments (Terms of Use)

Description Reuben Farrelly 2005-11-21 06:38:40 UTC
At present if we attempt to serve up OpenOffice documents with Apache, the mime
type is not recognised - it defaults to txt/plain:

ie:

[root@tornado ~]# telnet www 80
Trying 192.168.0.6...
Connected to www.
Escape character is '^]'.
HEAD /files/Resume%20-%20NZ.odt HTTP/1.0
Host: drupal.internal.net

HTTP/1.1 200 OK
Date: Mon, 21 Nov 2005 06:28:01 GMT
Server: Apache/2.0.54 (Fedora)
Last-Modified: Mon, 21 Nov 2005 06:12:55 GMT
ETag: "6bc-66e6-2d86e7c0"
Accept-Ranges: bytes
Content-Length: 26342
Cache-Control: max-age=86400
Expires: Tue, 22 Nov 2005 06:28:01 GMT
Connection: close
Content-Type: text/plain; charset=UTF-8

This is a problem because the client browser cannot handle the unknown format,
and we end up with rubbish in the browser (in my case, Firefox).

A document describing the new mime types is here:

http://framework.openoffice.org/documentation/mimetypes/mimetypes.html

Please add these to /etc/mime.types so that they are system wide.  I think this
would be a better idea than adding them to httpd.conf.

Comment 1 Miroslav Lichvar 2006-02-13 13:00:39 UTC
Fixed in rawhide.

Comment 2 Miroslav Lichvar 2008-03-11 13:57:17 UTC
*** Bug 201007 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.